3

When I migrated my old Mac to my new one, I copied some applications over from /Applications on the old Mac. Some of these were App Store apps, which I of course had to reinstall from the App Store in order to actually run them.

What's happened though, is there are some apps that appear in duplicates, with a white nondescript document icon like so:

enter image description here

What's going on here? Can I fix this? I've tried reindexing Spotlight both through the GUI exceptions and via Terminal and scutil, but to no avail. I've also tried searching "This Mac" for the files, but they don't appear in Finder search results anywhere. The plot also thickens when you compare the created/modified dates of the duplicate to it's proper original: they're always the same.

10
  • A couple of ideas: (1) Do you see the duplicates in System Information.app → Software → Applications? (2) Does sudo ls /Applications reveal anything interesting?
    – Bob
    Mar 8 '17 at 22:05
  • Also, if you are using Spotlight to back up to a local HD have you excluded that drive from the Spotlight index? Mar 8 '17 at 22:13
  • Nice @Bob - sudo ls /Applications showed nothing out of the ordinary, but some of the duplicates do appear in System Information.app → Software → Applications. Catch: not all of them do, e.g. this particular example of Sketch. Thinking this might be a red herring? Most of the paths that appear on the dupes that exist are in /Downloads. Mar 8 '17 at 22:19
  • @SteveChambers not the case here. Mar 8 '17 at 22:19
  • @brandonscript Did you mean /Downloads or ~/Downloads?
    – Bob
    Mar 8 '17 at 22:27
0

Go to /Library and do a search for whatever junk you're trying to get rid off. This happened to me for Cisco WebEx where I had 7 versions (most of them junk). Re-creating the index etc won't help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .