I have a MacBook Pro 2015.

I want ctrl+alt+up/down to map to duplicate line above/below in Intellij, but it is intercepted by macOS and causes the window to maximize to top/bottom of the screen.

I can't find where that mapping is in the keyboard shortcuts.

Does anyone know how to remove the mapping from macOS?

  • What version of macOS (or OS X, etc.) is on your MacBook? In a comment on an answer you mention the system default. It doesn't seem to be the system default on the first computer I tried, with OS X El Capitan 10.11.6. – D A Vincent Mar 9 '17 at 10:29
  • 1
    I've found a solution: I previously used Karabiner to map CONTROL_L to COMMAND_L, and it caused this problem (so the actual Mac shortcut is command + alt + up/down). Then I noticed Karabiner has a mapping for PC users, which only maps CONTROL_L to COMMAND_L in certain key combinations. This solved the problem. – stackoverflower Mar 9 '17 at 10:41

All native macOS shortcuts are mapped through Settings > Keyboard > Shortcuts

You can search through all the lists and look for the following combination in the right hand column: ⌃⌥↑. When you find it, you can either disable the checkbox in the far left or change the shortcut by double clicking it and entering a new shortcut.

You should now be able to use that shortcut in any program that the developer has mapped that for.

  • 1
    @Tetsujin Sorry, but I'm not sure what you're saying... I'm suggesting remapping the system default ⌃⌥↑ shortcut, then using the app as the developer intended. – Jackson1442 Mar 8 '17 at 18:11
  • 1
    Actually, I've found a way out: Karabiner has a mapping for PC users, and I just used it to remap the keys. It is working fine now. – stackoverflower Mar 9 '17 at 10:38
  • Thanks @stackoverflower and may I edit the answer to mention the possible Karabiner solution? – D A Vincent Mar 9 '17 at 10:57
  • 1
    @DAVincent yep please feel free – stackoverflower Mar 9 '17 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .