3

Or how can I export them? Or even just print them?

There are far too many for me to do them over.

4
  • Can you please provide more details re your situation? Are you transferring from one computer to another computer? Are you upgrading a single computer from Mavericks to Sierra? Or are your Mavericks rules data stored in some sort of backup? Something else?
    – Monomeeth
    Mar 8 '17 at 9:47
  • I have an old MBP with Mavericks. I have a new MBP with Sierra. I transferred the old mail on the old MBP to the new MBP. The email transferred
    – emaven
    Mar 9 '17 at 5:02
  • I have old MBP with Mavericks and new MBP with Sierra. I transferred old mail on the old MBP to the new MBP by importing all my local mailboxes. Mail that wasn't in local mailboxes was and is still on imap servers. Local mailboxes all imported perfectly. Folder hierarchy was preserved. Now I want my rules to be applied to my inbox so I can move the mail out and into the local boxes. But there are no rules. I transferred the old rules plist but they are not seen. I have lots of email addresses and lots of rules. Too painful to do one by one again. Especially if I can't see them.
    – emaven
    Mar 9 '17 at 5:10
  • Anybody have any solutions?
    – emaven
    Mar 18 '17 at 12:34
2

There are a couple of things you can try, but these seem to be a bit hit and miss (i.e. they don't seem to work in all cases).

Before I go any further, Apple Mail rules are stored in a property list at: ~/Library/Mail/V2/MailData/SyncedRules.plist

Notes:

  • The "~" in the above path denotes your user account name.
  • The "Library" folder is hidden by default. In order to see it, go to the Finder and while you press and hold the option key, click on the Go menu and select Library from the drop-down menu.
  • In your case it may not be in the 'V2' folder - it could be in a 'V3' etc, but in Mavericks the default was 'V2' and in macOS Sierra it should be 'V4'.

Method 1 - copy the SyncedRules.plist file

This is what I'm guessing you've already tried. Namely, find the correct copy of your rules .plist file and copy/restore this across to the correct location within your new macOS Sierra location. By correct location I mean that in macOS Sierra there will probably be a new 'V4' folder - so copy the file into that folder!

Method 2 - create a new user account

This method involves creating a new user account but not enabling iCloud in it so you can access all your old rules.

More specifically:

  • Go to Apple > System Preferences
  • Select Users & Groups
  • Create a new User Account (you may need to unlock the padlock in order to do this)
  • In Login Options ensure you have Automatic Login set to off, and that you have Show fast user switching menu enabled
  • Exit System Preferences
  • Log into your new user account but do not log in to iCloud (i.e. totally skip this step)
  • Copy across your V2 or V3 etc folder into the Mail folder located within the user's library folder (see notes at beginning of answer on how to make the library folder visible)
  • Now open Mail
  • This should start a process to copy across all your Mail data from the V2 or V3 or V4 etc folder you copied across

Once finished, you should be able to see your rules etc. If you can, you can try to copy across this new folder to your other user's account (however, be aware this may not be preferable as you will replace existing data that may be more recent - although you could try just copying across the SyncedRules.plist file. Remember to copy it across to the correct location (see Method 1 above). However, if you have iCloud enabled, you may want to also copy this across to the

If this doesn't work, but you can see the rules, then at least you can now see them if you need to take screenshots etc to recreate them.

Let me know how you go - especially if you feel you're close but just not quite there.

1

There's an easier solution than Monomeeth proposed - and it actually does work. The prerequisite is that you do have a backup of your system before the upgrade wiped your rules.

The key point here is that if you have iCloud turned on (which most users probably do) your Mail rules are synced with iCloud by default. The solution with creating new user is too long and much of a hassle. Do this:

  1. Quit Mail.
  2. Open iCloud Preferences (System Preferences → iCloud)
  3. Open options for iCloud Drive as shown below: enter image description here
  4. Make sure you uncheck Mail from the list of apps that store data in iCloud: enter image description here
  5. Find your Mail rules file in your backup, the file you're looking for is ~/Library/Mail/V2/MailData/SyncedRules.plist (folder name could be different depending on your backuped system, "V2" is for Mavericks, "V3" is for El Cap, "V4" is for Sierra)
  6. Copy that file over to your current system, into: ~/Library/Mail/V4/MailData/ (again, V4 beacuse it's assumed you're on Sierra)
  7. Now, open Mail, go to Preferences → Rules, and you will see all rules back in place, however all disabled. Now just check all and you're good to go!

Cheers :)

1
  • I just wanted to upvote it because I was having trouble moving my mail to Mojave... but obviously I can't ;) but the solution still works!
    – bzx
    Feb 4 '19 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .