1

I recently bought an iPod Touch 6 and synced my entire music library, but some of my albums are not showing up under the artist. For instance, I would click on Demi Lovato, and a couple of her albums will be there, but other ones won't be. If I search for those albums, they're on the iPod, it's just really frustrating that they're not sorted with the artist.

I've noticed that the albums I'm having an issue are albums that I originally ripped from CD's, but I don't think that's the reason because if it was, I'd be having trouble with a LOT more albums than I am. (Right now I'm only having trouble with three albums that I've noticed, but there might be more I haven't discovered yet. My music library is pretty substantial)

Any help would be much appreciated!

1

This may or may not help you, but I actually had the same problem. Which lead me to this page because I did a Google search.

I had an artist with 11 albums in iTunes. But on my iPod it only showed 10 albums. However, when I searched for specific tracks on the "missing" album they would show up and play fine.

I messed around with iTunes a little and followed the other answer's suggestion. I selected the album in artists view, right clicked on the album art (this will open up the properties for the entire album, not for a specific song. You can also make changes and apply them to the entire album rather than having to go song by song).

At the bottom of the window there is a box "Album is a compilation of songs by various artists." Somehow, that was checked. Which is odd because way back when I started ripping my CDs to iTunes I would let iTunes download the information for the CDs from their database. Anyway, I unchecked that, synced the iPod again, and the 11th album showed up under the artist.

0

A potential issue is that the artist name isn't exactly the same (maybe just an extra space etc), could be something else though.

  1. Open iTunes on your computer
  2. Highlight the affected songs (one artist at a time)
  3. Right click on one of them, and select "Get Info".
  4. Ensure that the spelling of the artist name is exactly the same as it is for the songs that show up properly. Any changes you make here will apply to all songs selected.
  5. Plug in and sync the iPod.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .