2

I have a small problem with my apps folder (/Applications/).

Whenever I change the view settings, for example, the size of the text, and click "Use as standard", it works fine.

But after some time, definitely after reboot or logout, those settings are not applied anymore and the old, ugly style is being used.

I heard that the file .DS_Store contains these settings. There is none in my apps folder, so I created one, but it didn't even save, no warning or error was given.

In all other folders, this works fine.

Does anybody have an idea to make my apps folder to stick to the chosen view settings permanently?

1

First of all, Finder uses a binary file format for this and you can't create the .DS_Store file yourself. Only Finder can do that (and usually will create it after you have first accessed the folder).

In case of the /Applications folder, it might be that you don't have administrator privileges which might prevent saving the .DS_Store file.

So you should check the permissions on this folder and set it to writeable by your user. This is not possible however if you're not the owner of your system.

I've searched the net and found other people having similar problems like you.

First thing suggested was to delete the Finder permissions file:

~/Library/Preferences/com.apple.finder.plist

can you try to do that, then logout/reboot and tell me in a comment if the view settings persist?

Edit: even if you're currently the only user, it's possible that your computer had previous (now deleted users) with the admin rights set for some folders on your system including the /Applications folder. You then need to set the rights to your user. Usually changing the permission modes should not be necessary.

  • Thanks for your answer. I've tried deleting that file, changed the view settings and logged out. When logged back in, it was reset, just like before. BTW: I'm the only user on this machine. How do I set the proper permissions for that folder? – thaikolja Mar 7 '17 at 22:10
  • 1
    CMD + I on that folder to get the Info window, check Sharing & Permissions part. If you're the only user you're the Admin. Then check if Admin is set to 'read & write' or 'read only'. When it's already read & write the problem is likely not solved in this way. – hyph Mar 7 '17 at 22:15
  • Thanks to all. I ended up installing a fresh OS which, obviously, got rid of the bug. But I'm your answers might be helpful for users having similar problems. – thaikolja Nov 9 '17 at 22:20
1

Finder view settings are stored in invisble .DS_Store files, in the parent of the folder being set. So the settings for /Applications are stored in /.DS_Store, and /Applications/.DS_Store holds the settings for subfolders of /Applications, such as /Applications/Utilities.

Normally you have write permission to these files in one of two ways:

  • For system folders such as /Applications, the .DS_Store files have write access for members of the admin group, i.e. administrators.
  • For folders that you create, you are the owner of the .DS_Store file.

The problem is that the permissions can get screwed up. One way is via the macOS Migration Assistant: the migration changes the permissions on some .DS_Store files to be owned by root, but with no write access granted to the admin group. This results in the systems you describe.

A fix is to first run this command:

 sudo find -x / -name .DS_Store -user root -exec chmod -v g+w {} \;

which will give the group write access to any .DS_Store files owned by root.

That still won't fix all of the files; there may be a few stragglers (such as, /.DS_Store) where the migration has changed the file to the wrong group, such as wheel instead of admin. You can fix that with the chgrp command, e.g.:

 sudo chgrp admin /.DS_Store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .