2

How do you get Pages on Mac Yosemite 10.10.05 to recognise different languages for spelling? When I write in German, everything has a squiggly red line under it and there is no option to change the language when I go into Spelling...

When I go into System Preferences > Keyboard > Text, in the dropdown list under Spelling I’ve chosen Automatic by Language. I even tried changing it to Deutsch, still doesn’t work.

Under Language and Region on System Preferences, my Primary Language is English UK, followed by German followed by Spanish. Nothing changes in Pages even if I make German my primary language.

Also, I've tried to change my region in Language and Region preferences, and it keeps changing back.

1

In Pages 5 or 6, go to Edit > Spelling and Grammar > Show Spelling and Grammar and set the dictionary to the language you want (not Automatic).

In Pages 4, go to Inspector > Text > More > Language and do the same thing.

If you want to try Automatic, which may or may not work very well, be sure to go to system preferences/keyboard/text/spelling/setup at the bottom of the list and check only the boxes for the languages you want.

(The OS version doesn't matter)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .