2

I have found that if one disables the built-in "Search With Google" and "Look Up in Dictionary" systemwide "Searching" Services, they are not actually disabled.

In this post, I focus on the "Search With Google" Service in particular (as it is more problematic for me; I explain why in a moment), but the "Look Up in Dictionary" Service misbehaves in exactly the same way.


The "Search With Google" system-wide "Searching" Service, enabled on Macs by default, opens up a Google search containing the selected text in a new tab in Safari. While the search engine can be changed, the browser cannot be changed in this Service.

However, my web browser of choice is Google Chrome.

I would like to disable this Service because I have recreated an identical version using Automator and AppleScript (so that I can implement the search in a new Chrome tab, instead of Safari). I am having trouble disabling this Service.

As you can see, the "Search With Google" Service and "Look Up in Dictionary" Service are unselected in System Preferences:

System Preferences

Yet, these two Services reliably pop up in my context menu:

Context Menu

I've tried restarting my computer and resetting the PRAM and SMC.

Following the instruction of this Stack Exchange answer, I've tried creating a custom Service with the same title as the built-in Service, hoping that my Service would "overrule" the original. But, alas, this did not work; my custom Service shows up as a "Text" Service, not in the "Searching" category. They have identical titles, but they coexist.

By the way, I noticed this problem as soon as I started paying attention, around 1 year ago.

It may be worth noting that if (and only if) I am in Chrome.app, the "Search With Google" Service does in fact disappear ("Look Up" still appears, though). But, I think that the reason for this is because Chrome, by default, inserts Search Google for "selected text" into the context menu when one is in Chrome; I am guessing that Chrome has some mechanism of automatically disabling the Safari Service, irrespective of the setting in System Preferences.

Is there a way to do so system-wide, maybe via Terminal?

Do you experience the bug on your Mac? I could not find even one account of this bug online.

OS X El Capitan, version 10.11.6.

You must log in to answer this question.

Browse other questions tagged .