3

When I go to Kickstarter.com, this is the site I see: enter image description here

Now, I have tried trouble shooting this by myself. I have deleted the website information from the privacy tab, I have turned off / uninstalled all extensions 3rd party or otherwise.

None of these steps restores the website.

Interestingly even Google Chrome does not work:

enter image description here

Does anyone know what is going on?

  • Did you try to foce reload? – Edric Mar 4 '17 at 15:47
  • Sounds like Kickstarter is down for you. Try again in a few minutes (or now, it seems to be up for me!). – owlswipe Mar 4 '17 at 15:54
  • @owlswipe it has been "down" for weeks.... – SumNeuron Mar 4 '17 at 15:55
  • @Edric I believe so – SumNeuron Mar 4 '17 at 15:55
  • @SumNeuron Have a proxy, firewall, etc. on your computer or router that could be messing with it then? – owlswipe Mar 4 '17 at 15:56
1

The error "NET::ERR_CERT_REVOKED" indicates that one of the certificates in the certificate chain was revoked. The kickstarter site works for other users here though.

Either the kickstarter (*c.ssl.fastly.net) or the root/intermediate certificate (Global Sign Root/Global Sign CloudSSL CA) was revoked erroneously or temporarily. The revocation is still stored in your ocsp/crl cache.

After deleting the caches the chain of certificates (and https://kickstarter.com) should work again:

in 10.11 or older open Terminal and execute:

sudo rm /var/db/crls/*cache.db

in 10.12 (Sierra) use this command instead:

sqlite3 ~/Library/Keychains/*/ocspcache.sqlite3 'DELETE FROM ocsp;'

After deleting the cache reboot your Mac.


Probably related: NET::ERR_CERT_REVOKED in Chrome, when the certificate is not actually revoked

1

The URL https://www.kickstarter.com is not broken for Safari Version 10.0.3 (12602.4.8) out of the box.

You are clearly getting bad web content to render and the suggestions in the comments are all spot on:

  1. This can be caused by web filtering / MITM (man-in-the-middle) type network meddling. You can test for that by taking your Mac to another network (coffee shop, public library, another country (not China or North Korea for instance).
  2. JavaScript blockers could cause this. Disabling JavaScript does change the rendering of Kickstarter for me, but the breakage is far less than what you report. Yours looks like the CSS isn't even loading.
  3. Check for CSS changes/overrides you have made to your browser or system.
  4. Web Privacy plug in (or network level controls) could cause this.
  5. Bad settings on your user account could cause this. To test that, make a brand new user account.

From your testing on Chrome vs Safari - it's highly likely you have a hostile network and/or software on your Mac that's rewriting the web content being served to you and breaking it.

  • Thank you bmike for your advice. I have tried different networks all yield the same result. I have no JS blockers currently. I have not made any CSS overrides. No plug ins of that type. I only have Zotero as a plug in. Ill try a new user account – SumNeuron Mar 4 '17 at 19:02
  • You've done many of the easy things. Something is certainly broken. Please edit my post to indicate the solution when you find it or pop in your answer and accept it, @SumNeuron – bmike Mar 4 '17 at 19:06
  • bmike indeed, something is wrong. I'll keep you posted :) – SumNeuron Mar 4 '17 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .