7

I am having trouble downloading an iOS 10.x Simulator on Xcode. After spinning and waiting for up to a minute, a popup with the following message appears:

Could not download and install iOS 10.1 Simulator. The network connection was lost.

I can assure you that I have just fine Internet connection and I have tried this on multiple Internet connections. I have tried closing and repoening Xcode, restarting my computer, starting Xcode with sudo...nothing works.

What's weird is that I am able to download an iOS 9.x simulator just fine. What is going on that is preventing me from downloading the iOS 10.x simulator? Any debugging or troubleshooting steps to take?

1

Finally found a solution, thanks to this forum post!

The solution is to run Xcode in sudo mode, like so:

sudo /Applications/Xcode.app/Contents/MacOS/Xcode

This really ought to be fixed, it is not an acceptable normal user flow to require the Xcode app to be run from the terminal in order to workaround this error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .