4

Today one of my users sent me some screenshots showing my application running in "Tabbed Windows" mode, i.e. with all the usually-separate windows showing up as tabs inside a single window, like this:

enter image description here

This is very cool, especially since I never actually programmed in any support for a "tabbed windows mode" in an application. :)

Unfortunately the user doesn't know how he got the application into this mode, and I can't figure out how to do it either.

When I Google the subject, I find articles like this one describing how this mode was added to some of Apple's own apps, and how MacOS/X will automatically added to any third-party apps that are "document-based"; for those apps, some additional menu items (like "Merge All Windows" and "Show Previous/Next Tab" and "Move Tab To New Window") will get automatically inserted into the Window menu.

However, my app isn't "document-based" AFAIK (it's a cross-platform app based on Qt5.4.1), and it doesn't have any menu named "Window". (It does have a menu named "Windows", but those menu items do not show up in that menu)

Does anyone know how my user pulled off this trick?

3
  • Command-T, maybe?
    – owlswipe
    Commented Mar 2, 2017 at 23:21
  • I tried that... it didn't have any effect when I did it :( Commented Mar 2, 2017 at 23:28
  • I went back to El Cap so I can't test this, but we have an app that isn't multi-window capable, where our users manage to get themselves into a similar situation. Cmd/Shift/T [& relaunch, in our case] is how we fix them.
    – Tetsujin
    Commented Mar 3, 2017 at 7:20

1 Answer 1

1

Just wondering what version of macOS you're running? The other user must be using macOS Sierra, what about you?

In macOS Sierra tabs are supported in any application where it’s possible to have multiple windows open. Based on your description, your app supports multiple simultaneous windows.

Assuming you have macOS Sierra installed, you can activate this in the way you found through your Google search. But if you haven't, then you won't be able to get tabbed windows to work.

If you do have the latest version of macOS Sierra installed, update your question and let me know. I'll see what I can dig up.

3
  • I tried under both Sierra and El Capitan; even under Sierra no extra items show up in the menus, and the hotkey (command-T) has no effect. Commented Mar 3, 2017 at 15:22
  • Did you see the comment by @Tetsujin ? Have you tried the Cmd+Shift+T (with and without a relaunch) to see what happens?
    – Monomeeth
    Commented Mar 3, 2017 at 22:27
  • I tried Cmd+Shift+T under Sierra just now (with and without relaunching the app), AFAICT it had no effect. Commented Mar 4, 2017 at 3:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .