6

I have a MacBook Pro (Retina, 13-inch, Early 2015) that I just reinstalled macOS Sierra 10.12.3 and now I am trying to use my Watch to unlock.

I had this working before in the past before the reinstallation. Also, I have it working on another older MacBook Pro. (Post 2013)

I get the following dialog:

Your Apple Watch must be signed into iCloud to allow it to unlock your Mac. You can sign in using the Apple Watch app on your iPhone.

After trying the following steps, I still get the dialog.

  • Verified that the Apple Watch is indeed signed in on the proper Apple ID
  • Verified that macOS is signed in on the same Apple ID
  • Rebooted the Apple Watch and unlocked it (See this answer)
  • Verified that all components are on the same WiFi network and Bluetooth is enabled

I have not unpaired the watch then paired again. Hoping not to have to go to that extreme.

Question: How can I get past the dialog? What am I missing here?

Hardware:

  • MacBook Pro (Retina, 13-inch, Early 2015) running macOS Sierra 10.12.3
  • iPhone 7 iOS 10.2.1
  • Apple Watch 1st generation watchOS 3.1.3

System Preferences Dialog Watch AppleID Settings

7

I had the same problem: In settings I was definitely logged into iCloud, but the Apple Watch unlock setting still claimed I wasn't.

I stumbled on the following weird solution:

I happened to start FaceTime on Mac, and noticed that I wasn't logged into it. I logged in.

When I then opened the Security settings again, the Allow your Apple Watch to unlock your Mac was checked!

  • Same for me after a Mojave upgrade - thanks! (I also ran the Watch app and visited General->AppleID, but since it was already logged in there was nothing to do there.) – Graham Perks Sep 30 '18 at 21:38
  • 2
    I was logged in, but logged out and in again to FaceTime and that fixed it. – Rivera Nov 7 '18 at 12:46
3

It appears that macOS needed to be rebooted.

To solve the problem:

  • Be sure all of the above steps in question have been done
  • Reboot MacBook
  • Verify the settings in System Preferences > Security and Privacy

Now the unlock with Watch is working.

System preferences dialog

1

I had the same problem and I tried EVERYTHING to fix it. Saw your note about not being signing into Facetime. Well, I was signed into both Facetime and Messages, but I thought, what the heck. Unchecked Enable this Account in Messages setting, then re-enabled it and voila, my Apple Watchs showed back up as options to check to unlock my Mac again.

You must log in to answer this question.

protected by Tetsujin Oct 21 '18 at 9:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .