0

I have laptop with macOS Sierra 10.12 and shared printer Kyocera_FS_1120MFP_GX which is connected to PC with Windows 7.

If I connect it directly to my laptop via USB it works, but if I try to connect it via local network it show me Print queue window with Hold for Authentication.

For other windows PCs it works ok. I tried some commands in terminal: lpstat -p shows printer Kyocera_FS_1120MFP_GX is idle. Authentication required

lpstat -s shows default Kyocera_FS_1120MFP_GX: smb://ks2-pc/Kyocera%20FS_1120MFP%20GX

Also I tried sudo lpadmin -p Kyocera_FS_1120MFP_GX -o auth-info-required=negotiate but it change nothing.

How to fix it?

1 Answer 1

2

Figure it out: You should open keychain access tool and find there your printer name in the keys list and remove it.

After that open Print queue window and select in the top menu: Printer - print test page. Window with login password will appears. Print there username - guest without password. After that printer should work.

1
  • Finally an answer that worked, I tried everything without success till this. Thanks!
    – chifliiiii
    Commented Jul 13, 2020 at 15:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .