2

My MacBook Pro runs El Capitan. By mistake, I installed Nokia's flasher 3.12.1 (which they say is for Harmattan - to be honest, I do not really know what this means, but I content myself to know this is the wrong one). It is a command line utility. Now I would like to uninstall it, but I do not know how to locate all related files (they are spread in various locations - this is all I know). I tried to run again the installer and look at its log, but I cannot understand it. Any idea?

  • 1
    Can you provide a link to the exact software you installed? – grg Mar 1 '17 at 19:16
  • @grgarside - software probably downloaded from here. Can't find any other Mac-based Nokia flash apps with my limited Googling skills. :-/ – IconDaemon Mar 1 '17 at 21:11
0

The package available for download at MacFlasher_3.12.1.dmg contains the following files which you can remove manually. You can also remove the package receipt from /var/db/receipts/.

                                                  

To find this list of files from the package, I extracted the package to a custom location using the following, then inspected the contents of the temporary directory.

pkgutil --expand /path/to/nokia_flasher.pkg /path/to/temporary

For an automated solution, try using UninstallPKG. This will parse the package receipt and allow you to remove the files.

  • This is exactly what I need. How did you find the various files? Did you install the package and read the receipt? – Enrico Mar 1 '17 at 19:27
  • @Enrico See edit, you don't need to install the package. – grg Mar 1 '17 at 19:31
  • Well done, I successfully deleted everything. Now I would like to install the flasher 3.5. It is designed for a 32 bit system (I think it would run on Lion). The installer shows up a warning about the program being possibly harmful for my system. What can I do? Maybe it is better that I post another question? – Enrico Mar 1 '17 at 19:47
  • @Enrico Yeah maybe worth a separate question but also try searching first. I have no experience with this specific software but that message sounds like Gatekeeper. The MacFlasher package mentioned in this question didn't have a Developer ID and threw Gatekeeper for me initially. Try right-clicking on the package, then selecting Open, then Open on the modal that now appears. – grg Mar 1 '17 at 19:50
  • I tried right-clicking etc. but with no result. The error message says "This package is incompatible with this version of OS X and may fail to install" and also notes that it may damage my system. So I don't want to try unless I'm sure of what happens. I don't think this message is due to Gatekeeper. I already removed com.apple.quarantine from the package attributes. – Enrico Mar 1 '17 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .