I recently noticed that I had about 4 or 5 Google Chrome Helper processes running in my Mac. I have no windows opened on chrome and it seems that the Helper processes still stay there regardless. I looked at the other question Why does Google Chrome launch multiple instances of Google Chrome Helper? and this good article explaining what the issue is and how to solve it. They suggest to follow the following steps:

  1. shut down all your Chrome windows without quitting the program.
  2. go to “Preferences,” scroll all the way down in the menu
  3. click on “Show advanced settings…”
  4. The first item in the expanded advanced settings list will be “Privacy,” and click on the “Content Settings” button right under that.
  5. (step that fails for me) About halfway down the content settings list is a “Plug-ins” entry, which will likely be set to “Run automatically.” Instead, select “Click to play.”

The instructions are clear and easy to follow but it seems that the plug-ins button doesn't exist or it was moved. Does someone know where the plugins section went to?

I don't know even if we find the new section for the plugins if it would solve the problem, but if it doesn't, can we truly get these chrome helper processes to go away?

As a side remark, I did go to the extensions section of chrome and I disabled all of my extensions, however, I still have at least 3 chrome helper windows running. Why is that? Can we get rid of them in anyway?

It seems that the main issue is that the new extension section has no clear (analogous to the article) way of preventing auto-helping to enable. This seems to be my main goal. To have the auto-helping turned off. In particular I want it to work as this sentence of the article suggests:

Disabling Helper’s auto-helping is easy, and it won’t prevent you from using plug-ins.

Right now the extension section has no analogous section to the "Click to play" which seems to play the following important role:

This is essentially the same thing as configuring email to load images only when you click a “load images” link. Any embedded Flash, Java, Quicktime, DivX, or Silverlight content on a webpage will appear as a grayed-out space until you click on it to load the player and the content.

Right now the only way that (very) unreliable works is disabling the extensions. Which is of course not the solution I want or the solution the article alludes to.

Is there a "Click to play" in the new chrome for mac?

  • "Google Chrome Helper" could be literally anything. Chrome's task manager will tell you what they actually are, so you can clarify your question.
    – Josh Lee
    Mar 3, 2017 at 1:50

4 Answers 4


The Wired article is a bit old and perhaps is no longer current. 'Extensions' are what you're looking for, and they can be found in the menu item Window > Extensions.

You can also use Window > Task Manager to look at all the tab processes and extensions:

enter image description here

  • I did see the extension window as I said in my question. Its the way I guaranteed that the chrome was not running the helper window. But it seems that even if I go there and disable all the extension those pesky windows keep coming up by themselves. Mar 1, 2017 at 17:40
  • The task manager is also accessible via the chrome menu button (the three dots on the right, not sure what its officially called) under "More Tools >"
    – rebusB
    Jul 26, 2018 at 15:07

Unfortunately, the modern day versions of Mac Chrome doe not seem to have "Unsandboxed plugin access" in Settings anywhere. I'm using Chrome 89.0.4389.90 (Official Build) (x86_64) for Mac. I am using macOS Big Sur v11.2.3 for reference. If anyone knows where to find it, please let me know. My Macbook Pro's relatively new batter, with only 60 cycles on it, that should last 8-12 hours, lasts a mere 3.5 hours with chrome running. I've deleted all but 1 extension (to my dismay as I love my extensions!) and it still isn't helping. Activity Monitor is showing 13 instances of "Google Chrome Helper (Renderer) running, among other tasks. Oy vey -- any help much appreciated, as I've used MacBook Pro's with Chrome for the last 15 years without this type of battery challenge. Thank you!


Since Chrome no longer allows you to disable "Google Helper" here is something else you can do to figure out what extension within Chrome is eating up your resources.

For Mac: Go to the Google Chrome Task Manager. On a Mac go to Window >> Task Manager.

Here is a video showing this process: https://www.youtube.com/watch?v=fQLh-M4LrHU

Hope this helps!


If you are feeling daring you could go through the chrome:\\flags (just put that in the address bar) to see if any help control background processes. The Throttle expensive background timers and Stop in Background look promising and there is one that disables autoplay. There is a search field on the page for locating the flags you want. Be warned, changing these could radically effect Chrome's behavior!

To answer your question: Chrome Helpers are core to Chrome functionality, they are not plug-ins per se. However there is a "Unsandboxed plugin access" setting in the advanced preferences which may be what you were looking for.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .