7

I have a very similar problem as outlined here. Several fresh installations of 10.12.3 as well as the beta did not fix the sudden restarts.

I'm using a Mid 2014 MacBook Pro Retina with dedicated GPU.

Do you see some things to try?

  • several reinstallations did not help (also the reset installation)
  • hardware test does not report failures
  • no problems with SSD disk utility
  • already reset NVRAM
  • the problem does not seem to apprear in safe mode (but safe mode ist not really a mode to work in)

Feb 28 18:41:37.190986 +0100 000001.269937 Brcm4360<D>[1794] [0xbfc5df44490844e7][1][0] CoreCapture:reinit@35=PCIErr-Status{LnkSt=10110143,DevSt=123C10,VID=14E4,DID=43A0,STS_CMD=8100406,BAR0=C1A00004,BAR1=C1800004,US=8000,CS=1
Feb 28 18:41:37.190987 +0100 000001.269938 Brcm4360<D>[1795] [0xbfc5df44490844e7][1][0] Skip capture: Capture:0, wl_powercycle_inprogress:1
Feb 28 18:41:37.190989 +0100 000001.269940 Brcm4360<D>[1796] [0xbfc5df44490844e7][1][0] Fatal Error - Initiate powercycle 
Feb 28 18:41:37.190991 +0100 000001.269942 Brcm4360<D>[1797] [0xbfc5df44490844e7][1][0] wl_fault_powercycle: thread_call_enter1 - Power Thread scheduled
Feb 28 18:41:37.190992 +0100 000001.269943 Brcm4360<D>[1798] [0xbfc5df44490844e7][1][0] Perform hard reset, skip core init
Feb 28 18:41:37.190993 +0100 000001.269944 Brcm4360<D>[1799] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::syncPowerState: Device in bad state after wakeup - err:-1
Feb 28 18:41:37.190995 +0100 000001.269946 Brcm4360<D>[1800] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::syncPowerState: Device in bad state after wakeup - err:-1
Feb 28 18:41:37.190998 +0100 000001.269949 Brcm4360<D>[1801] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::syncPowerState: returned: powerStateOrdinal = 2, callback[2] systemWoke[0] _powerSleep[0] _powerState[2]
Feb 28 18:41:37.191000 +0100 000001.269951 Brcm4360<D>[1802] [0xbfc5df44490844e7][0][0] AirPort_Brcm43xx::setPowerState: powerStateOrdinal = 2, ACK'ing.
Feb 28 18:41:37.191004 +0100 000001.269955 Brcm4360<D>[1803] [0xbfc5df44490844e7][1][0] powerCycleOffOnThread - Start Powercycle..., _powerOffOnDelayms[ 300]
Feb 28 18:41:37.191009 +0100 000001.269959 Brcm4360<D>[1804] [0xbfc5df44490844e7][1][0] powerCycleOffOnThread: M_DRIVER_AVAILABLE:0, event:0, reason:e0823801, sub_reason:e3ff8d23, minor_reason:0, reasonString:reinit@35=PCIErr-Status{LnkSt=10110143,DevSt=123C10,VID=14E4,DI
Feb 28 18:41:37.191011 +0100 000001.269962 Brcm4360<D>[1805] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::powerCycleOffOnThread: calling setPOWER(OFF)
Feb 28 18:41:37.191013 +0100 000001.269964 Brcm4360<D>[1806] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::setPOWER(): >>>> _powerState[2] _lastUserRequestedPowerState[2] _systemSleeping[0] _powerOffInProgress[0] _powerOffThreadRequest[1], _powerSleep[0] pid[0]'kernel_task'
Feb 28 18:41:37.191015 +0100 000001.269966 Brcm4360<D>[1807] [0xbfc5df44490844e7][1][0] wl0: setPOWER: num_radios[3]  power_state(0:0  1:0  2:0  3:0)
Feb 28 18:41:37.191017 +0100 000001.269968 Brcm4360<D>[1808] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::setPOWER(OFF): _powerState[2] _lastUserRequestedPowerState[2] _systemSleeping[0] _powerOffInProgress[0] _powerOffThreadRequest[1] selfpid[0] inprogress[0]
Feb 28 18:41:37.191059 +0100 000001.270010 Brcm4360<D>[1809] [0xbfc5df44490844e7][1][0] wlIoctl: wlc_ioctl called with cmd 118 returned error -26
Feb 28 18:41:37.191061 +0100 000001.270012 Brcm4360<D>[1810] [0xbfc5df44490844e7][1][0] wl0: setAP: err setting ioctl WLC_SET_AP to 0, err -26 "Not Permitted"
Feb 28 18:41:37.191062 +0100 000001.270013 Brcm4360<D>[1811] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::setPOWER(OFF): calling changePowerStateToPriv( PS_INDEX_DOZE )
Feb 28 18:41:37.191070 +0100 000001.270021 Brcm4360<D>[1812] [0xbfc5df444908497f][0][0] AirPort_Brcm43xx::powerStateDidChangeTo: 2, timestamp[0x0000000000136103] calendartime[0x0005499ab530609c]

and

Feb 28 18:41:37.182899 +0100 000001.261850 Brcm4360<D>[288] [0xbfc5df444908497f][0][0] AirPort_Brcm43xx::powerStateWillChangeTo: 2, ACK'ing
Feb 28 18:41:37.182909 +0100 000001.261860 Brcm4360<D>[289] [0xbfc5df44490844e7][0][0] AirPort_Brcm43xx::setPowerState: Called powerStateOrdinal = 2, timestamp[0x0000000000134122] calendartime[0x0005499ab53040bb]
Feb 28 18:41:37.182911 +0100 000001.261862 Brcm4360<D>[290] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::syncPowerState: powerStateOrdinal = 2, callback[2]systemWoke[0] _powerSleep[0] _powerState[0] _down[0] _up[0] osh[0xbfc5df44491fd42f]
Feb 28 18:41:37.182963 +0100 000001.261914 Brcm4360<D>[291] [0xbfc5df44490844e7][1][0] wlc_verify_d3_exit: AER_UC_NON_FATAL: STS:00008000, SERV:FFF9DFCF
Feb 28 18:41:37.182967 +0100 000001.261918 Brcm4360<D>[292] [0xbfc5df44490844e7][1][0] wlc_verify_d3_exit: PCI_CFG_AER_CORR_STS: STS:00002000
Feb 28 18:41:37.182975 +0100 000001.261926 Brcm4360<D>[293] [0xbfc5df44490844e7][1][0] wlc_verify_d3_exit: PCI_CFG_STAT:00000810
Feb 28 18:41:37.182977 +0100 000001.261928 Brcm4360<D>[294] [0xbfc5df44490844e7][1][0] wl0: fatal error, reinitializing, total count of reinit's[1], @'wlc_verify_d3_exit':57164
Feb 28 18:41:37.182985 +0100 000001.261936 Brcm4360<D>[295] [0xbfc5df44490844e7][1][0] wl0: 802.11 reinit reason[35], count[1]
Feb 28 18:41:37.183053 +0100 000001.262004 Brcm4360<D>[296] [0xbfc5df44490844e7][1][0] wl_fatal_error: fatal error within 450 ms, limit:4000 ms. currentRetryCnt:1, max:3
Feb 28 18:41:37.183055 +0100 000001.262006 Brcm4360<D>[297] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::setPowerCycleInProgress: state [0] -> [1], name['wl_fatal_error'] id[31094]
Feb 28 18:41:37.183057 +0100 000001.262008 Brcm4360<D>[298] [0xbfc5df44490844e7][1][0] AirPort_Brcm43xx::setPowerCycleInProgress: _up[0] _down[0] _powerSleep[0] _powerState[0] _powerCycleThreadWaiting[0] _powerOffOnThreadBlockedForWake[0] _powerCycleOffOnThreadRunning[0]
Feb 28 18:41:37.183064 +0100 000001.262014 Brcm4360<D>[299] [0xbfc5df44490844e7][1][0] Log system state... : reinit@35=PCIErr-Status{LnkSt=10110143,DevSt=123C10,VID=14E4,DID=43A0,STS_CMD=8100406,BAR0=C1A00004,BAR1=C1800004,US=8000,CS=1
Feb 28 18:41:37.183066 +0100 000001.262017 Brcm4360<D>[300] [0xbfc5df44490844e7][1][0] wl0: Dec 22 2016 23:34:31 version 7.21.171.68 (TOB) (r667042)(P2P)

Feb 28 18:41:37.183068 +0100 000001.262019 Brcm4360<D>[301] [0xbfc5df44490844e7][1][0] KMOD info(name: 'com.apple.driver.AirPort.Brcm4360' version['1130.3.1a5'] 

edit

No panics reported, only diagnostics. However this link contains the full output for the AirPort crash mentioned above.

To clarify: the notebook will either freeze and then shutdown or go to black and shutdown. It will not restart automatically. And I do not see the grey screen of death indicating a kernel panic.

no panics

  • Can you recreate the problem at will, or does it happen randomly? Download and run Etrecheck and then post the output to Pastebin. Supply the link as a comment or just update the original question. All personal information is anonymized. – njboot Mar 1 '17 at 7:09
  • Here is the etrecheck output pastebin.com/mTyVnV9m. No, it is not reproducible. Sometimes every 15 minutes, sometimes every 8 hours. What I noticed though it does not seem to appear for the first boot after reinstalling OSX. – Georg Heiler Mar 1 '17 at 7:15
  • Thanks. Also, check /Library/Logs/DiagnosticReports folder (thats the full path, enter it from Finder > Go) and look for any log ending in .panic. If you have one, post the most recent one. – njboot Mar 1 '17 at 7:24
  • Best guess on kernel panics that don't happen in safe mode is usually a 3rd party kext. That would also tally with it not happening after a clean install. – Tetsujin Mar 1 '17 at 7:37
  • 1
    It's been happening to my late 2013 MBP 15" since yesterday. It's pretty constant on both my own and my parents' WiFi (completely different WiFi hardware). On my work WiFi or work ethernet, however, it just doesn't happen. – Ambroos Mar 17 '17 at 21:15
1

I finally have an answer:

Visiting the Apple Store did not help me. They could reproduce the problem and suggested that maybe changing the network card could help.

I finally negotiated an extra support option from apple and took my MacBook to a local repair shop. They identified the mainboard as the problem and changed it.

0

I have been having problems identical to yours. And, like you hardware diagnostics reported nothing wrong.

As a last resort, I took it to the Apple Store and requested they reseat the Airport wifi module. They agreed this was the next best course of action.

I'm happy to report that has solved all my problems. Might be worth a try for you. They also didn't charge anything, so it's worth a shot.

  • That sounds great. Unfortunately in my town there is no original apple store. And the retailers charge for that. Do you know if I can do this reset at home as well or if there is some tutorial? – Georg Heiler May 1 '17 at 5:34
  • I had them do the same at the Apple Store in Brussels, and unfortunately it didn't make a difference. (The display assembly was replaced, quality program, see staingate, and they reseated the WiFi card. No charge, out of warranty.) – Ambroos May 30 '17 at 13:13
0

I've had the exact same problem for quite some time. No kernel panics, but DiagnosticReports for the AirPort module each time. The reboots used to be very infrequent (several days) but more recently it would happen as often as every 5-30 minutes.

The AirPort kext seems to be the culprit for me. Disabling wifi/bluetooth and using ethernet did not prevent the problem from occurring like it has for others, although it does seem to make it less frequent.

After a fresh restart, I run this script to unload the kext and I haven't had a crash since:

sudo kextunload /System/Library/Extensions/AirPortBrcmNIC-MFG.kext

I'm not sure what features are disabled by unloading this kext, though.

  • I get Can't open CFBundle for /System/Library/Extensions/AirPortBrcmNIC-MFG.kext. Can't create /System/Library/Extensions/AirPortBrcmNIC-MFG.kext. when trying to run your script on OS X 10.12.5. – Georg Heiler Jun 8 '17 at 11:12
0

Can confirm that the only workaround preventing my MacBook from crashing with exact same signature is: keeping it connected to power, lid closed, thunderbolt dock with Ethernet (wifi can be ON). Removing ANY of that (power, lid or dock) criteria leads to a crash in few minutes

No solution so far https://discussions.apple.com/thread/7807562?start=0&tstart=0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .