I want to copy files from my SD card to my Desktop but for some of the files I get:

The Finder can’t complete the operation because some data in “GOPR0054.MP4” can’t be read or written. (Error code -36)

I tried to use dot_clean because it seems to have done the trick for others:

dot_clean Path/To/Directory

Didn't work.

I have no idea what error -36 is or how it can be solved. My SD card is in ExFAT format (if that matters).

I'm running macOS Sierra 10.12.2.

  • 3
    Error 36 is now and has, for a long time been an Apple file system error that boils down to "file is damaged" and/or "premature end of file" Its possible that a file recovery program or service could recover the file or its remains. Otherwise I would reformat the card and then do a whole lot of writing and reading to/from the card to make sure its not a bad card. Feb 28, 2017 at 19:58
  • 2
    @SteveChambers is correct on all three counts: (1) Error -36 is an input/output (I/O) error and this often means the file wasn't completed correctly for the particular file format, or that it's corrupted for some reason. (2) You're best bet is to use data recovery software (there are many) or a file extractor (such as File Juicer to see what can be recovered. (3) Reformat the card and really test it before using it for anything critical. There may be nothing wrong with it (the GoPro battery may have died while saving, etc), but you'd want to be sure.
    – Monomeeth
    Feb 28, 2017 at 21:16
  • Oh, and just to be clear, I have no affiliation with File Juicer whatsoever!
    – Monomeeth
    Feb 28, 2017 at 21:16
  • I had the same problem transferring from a flash drive to my iMac. I tried dot_clean as others have suggested. Still no real answer, but when I tried the same flash drive on my MacBook Pro, it worked fine. This leads me to believe the issue may be in the iMac itself. Oct 16, 2017 at 23:09
  • I had issues dealing with this with the Mac so I used a Win 10 machine to transfer the files and it worked fine. Bad form, Apple.
    – jcollum
    Mar 2, 2019 at 23:48

2 Answers 2


Not true; it's a privacy issue with the xfat format. You can copy the files via terminal: mv plus space, drag the file, plus drag the destiny. If that doesn't work, you'll have to change the format of the file.

  • How do I delete these files?
    – Anthony
    Sep 19, 2017 at 22:42
  • 1
    I tried both dot_clean and copying with the mv command. Every time I got OP's error. Dec 30, 2017 at 23:28
  • 2
    What's "not true"?
    – Simon East
    Jul 2, 2018 at 5:38
  • cp -r DIR DIR_TO worked for me. however it was not an issue of copying between disks; i was trying to copy a folder from my desktop (icloud) into another documents folder (icloud).
    – Leo
    Jun 6 at 20:59

I had numerous files filmed in high quality and it would throw the same error and I wouldnt be able to copy it. I could see it in preview and in FCPX but I couldnt export or copy it. What I did was compress the file that was not working directly on the SD card and then copy the compressed file to the desktop. After it finally copied,I then uncompressed it in desktop and voila. I had the file saved on the desktop.

  • After you've saved your files that couldn't be copied, format the card to give it a clean start. Mar 25, 2018 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .