1

I have a MacBook Air, mid 2012 running the macOS 10.12.4 beta. Since recently, my headphones stopped working. If I plug them in, the computer still uses the internal speakers. And if I go to system preferences, I still doesn't recognize my headphones. I've searched the web for this problem, and I saw that some other people have the same problem. I can only fix this by restarting, but that's very annoying.

Can anybody please help me?

  • same problem with me, for me it's normal ear phone. Sometimes restarting will help, but sometimes not. – haxpor Feb 28 '17 at 5:48
  • Have you diagnosed whether it's your headphones or MB? Have you tried plugging the headphones into a different computer or different headphones/speakers into the MB? – Allan Feb 28 '17 at 11:46
1

Although I have MacBook Pro Retina mid-2012, I have been experiencing the same issue since macOS 10.12.4 beta 3 and updating to beta 4 have fixed the issue for me. Try that.

  • Welcome to Ask Different. The preference is for answers to more than just a 1-line statement. Please back-up your answer with additional info, such as a document from Apple indicating the problem was fixed. If not, you risk having your answer voted down due to lack of supporting evidence. – fsb Feb 27 '17 at 21:18
  • Thanks for the information @fsb. Sorry for the short answer, however there's no information in the release notes from Apple that would indicate the problem has been fixed. I have been experiencing the same issue, and I wrote that from my experience. – Alex Qyoun-ae Feb 27 '17 at 21:53
  • If that's the case, it would be good to update your answer and indicate your experiences. That can be just as good as Apple documentation, however, it could also be specific to your system and not applicable to the OP. It's good that you're adding your findings here, thanks. – fsb Feb 27 '17 at 22:01
0

Restarting the OS X audio subsystem might fix the problem, without the need to do a full reboot. You could try running the following commands in Terminal

sudo kextunload /System/Library/Extensions/AppleHDA.kext
sudo kextload /System/Library/Extensions/AppleHDA.kext
sudo killall coreaudiod

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .