2

When I type a word into Spotlight (macOS Sierra 10.12.3) and I click on the dictionary (definition), it always comes up using the German dictionary. I have a German-bought Mac but work almost exclusively in English, so this is quite frustrating.

I have tried moving the English dictionaries to the the top of the list in Dictionary preferences, and also tried deselecting the German dictionaries altogether, with no changes.

1

Great question and it's one that comes up more often than not.

Here is a link to a similar question submitted to AskDifferent a few years ago: How to switch language of OS X dictionary?

You could also try this:

  1. Open the Dictionary app and navigate to Dictionary/Preferences.

Switchting Dictionary Languages

  1. In Preferences select or de-select the languages you prefer.

Dictionary Language Preferences

  1. It may be that 'German' is still set as the preferred language, so de-selecting it may then allow you to remove it as you were initially attempting to do.

Also, after making these changes, try restarting your Mac. Sometimes this helps things reboot in proper order and get rid of processes and other 'crud' that may be clogging the Mac's Memory.

'Hope this helps!

~

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .