2

After getting to the menu bar (which in OS/X is already a hassle) we can use the first letter to access the submenu - ‘w’ for ‘Window’ in the screenshot below:

Subsequently the ‘b’ was typed to access the ‘Background’ sub-submenu The question here is: how to expand it - without resorting to the arrow keys that are a big jump for the fingers and get them out of home row position?

What I tried: tab space enter. None of those work. Only right arrow: but once again that is inefficient - almost as costly as using the mouse. Is there any way to do this quickly i.e. with hands remaining on or near home row?

  • I have Sierra and once I'm on the specific command the space bar expands the menu item for me. – fsb Feb 26 '17 at 17:42
2

Space or Enter both open a highlighted submenu where the current option does not have an action by itself. Right Arrow works when the current option does have an action, but you wish to open the submenu (I'm not aware of a single instance of such a case where it's not a bug).

This works regardless of whether you use ⌃F2 or clicking to open a menu. I am using macOS Sierra, but am not aware of this functionality missing from prior versions of macOS.

JetBrains apps such as PyCharm have an unfortunate bug where their submenus aren't just submenus since you can select the top level menu item too (try clicking on the highlighted item in your screenshot). Space prefers to select where possible, which won't expand the submenu. This is a specific bug with such apps.

  • More specific than what? The screenshot shows the situation where I tried those various keystrokes -including space. Right arrow is the only one doing the trick. – javadba Feb 26 '17 at 22:38
  • re: space: apparently I had done so. I did not re-read my question and happened not to have recalled at that moment. – javadba Feb 26 '17 at 22:40
  • el capitan. The screenshot is from Jetbrains (correction from a moment ago when I said chrome) – javadba Feb 26 '17 at 22:41
  • @javadba That screenshot looks like PyCharm or another JetBrains app, not Chrome. I've edited my answer accordingly. – grg Feb 26 '17 at 22:42
  • ah ok so this is just JB apps. Thanks for that insight – javadba Feb 26 '17 at 22:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .