As in the title. iCloud calendar is not sending invites to people being invited. No matter whether I try via icloud.com or iCal.app synced with iCloud - it just doesn't. No events no updates. Tested sending to a gmail address and at least two other.

Why doesn't it?

Found this @ http://productforums.google.com/forum/#!topic/calendar/gtpX0F7kgKI

For what it's worth, I started having a similar issue recently and came across this thread while researching the solution. My wife has an iPhone, I'm Android, and she routinely sends calendar invites to me. We just realized that I've recently stopped getting those invites to my Gmail account, even though she's still adding me the same way she always has. It turns out that since my iCloud account is setup with my Gmail address, iCloud has started to "intercept" those invites from her iPhone. Instead of going to my email account, they're being automatically added to my iCalendar. This can be disabled by:

  • Logging in at https://www.icloud.com
  • Go to Calendar -> (Cog) -> Preference -> Advanced
  • Beside "Invitations" select Email To (Use this option if your primary calendar is not iCloud).

This may solve your problem if:

  1. Someone with an iDevice is sending your the invite.
  2. You have an iCloud account.
  • Big big thanks, this was driving me and my partner crazy!! – Stef Aug 23 '17 at 12:19

Here's what I found: when you send an iCloud calendar invite to someone's email address, if that address happens to be their AppleID username that is now also associated with iCloud, then Apple tries to outsmart the users, and routes that calendar invite instead to the recipient's AppleID/iCloud account calendar.

Here's a thread I started on it: http://forums.macrumors.com/showthread.php?t=1267665

  • I have a Google email address associated with an Apple ID. The Apple ID is NOT the email address. An invitation sent from an iCloud user's address to that Google email address did not generate an email to Gmail. Instead it generated an event on the (unused) iCloud Calendar belonging to the Apple ID that has an association with that Google email. In 2016, from iCloud.com Calendar. Wow. – John Faughnan Jan 21 '16 at 17:43
  • Additional thought: Since the person sending the invitation also had my iCloud address in her Contacts it's possible that the Gmail to iCloud switch occurred by reference to her Contact for me. – John Faughnan Jan 21 '16 at 17:49
  • This happened to me, too. My gmail address is also an Apple ID … but not the one my iPhone uses for iCloud … and if you send iCloud calendar invites there, I won't see them. – Paul Schreiber Feb 20 '17 at 0:55

I have found when I do not include a location with the invite it goes through. I have even edited earlier invites and removed the location and the invite is received

  • 1
    This indeed seems to be how this works (two years later!). Moreover, once a location is added, no subsequent updates to the event are ever sent (including the addition of the location). Great work Apple! – orome Dec 21 '16 at 21:23
  • This is indeed a known bug. – orome Dec 27 '16 at 13:51

Ok we have found a possible answer to this issue:

  1. If you are using any other mail address other than icloud.com as your apple id all your invitation is being redirected to your icloud calendar.
  2. If you do not sync your icloud calendar then you will remain unaware of the invitation.
  3. You can correct this by logging in to iCloud, accessing the calendar preferences and going to the advance tab and tick the bottom box to not use in app serviced but to send mail to your primary address

Please can someone force Apple to make this a default setting as the world is not on iCloud yet

My was not working either as of yesterday. I went into all of my events that I created yesterday and edited them to reflect a change so that an update email would have to be sent out. I did this to check if they were working and they myself and all of the invitees WERE sent emails this time.

Not real sure why, but it seems to be working now. Creating new events with invites also seems to work now. Go figure.

  • Still no joy for me :( – Michal M Oct 14 '11 at 14:01
up vote 0 down vote accepted

As in my previous problem with iCloud - it took a little bit of time for it to start working.

It's also worth noting, that calendar invites don't get delivered to email accounts that are configured in your Mail.app.

The person you are sending this to is using the email address as the log into iCloud. That person needs to log into iCloud and go to calendar on the bottom left is a gear click it go to preference and then up top click on advance. At the bottom on invitations In app should be highlighted as default under it click on use my email.

Seems to be new iCloud accounts, that hasn't assigned with phone number can't send invites, but can accept them. I've just created new iCloud (with gmail email) account, logon on the iPhone w/o SIM and no one invite was send to contacts. I've tried: phone numbers, different email addresses, via iPhone / iCloud.com, and get no inapp invite, no email. At the same time, I've received invitations in this account.

Probably, Apple denying sending invites from unphoned accounts to reduce calendar spam. But nothing that said in KB

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.