3

I have a problem with my friend’s iMac (mid-2010) that I'm fixing. I’ve replaced his hard drive with an SSD (the Samsung 850 evo) and after reinstalling the OS via recovery mode (cmd+R) it shows a folder with a question mark in it during the boot.

Here's what I've tried so far to fix it:

1) Tried another hard disk (used a 2.5” mechanical drive that I otherwise use for backups) and it worked without the issue on this one.

2)Tried upgrading the sata cable with a new one but it didn’t work.

3)Run First Aid From Disk Utility. The SSD is ok:

SSD ok after first aid

4) Tried to select the Startup Disk, but the SSD doesn’t show up! What’s strange is that I can see the SSD in Disk Utility and I was even able to perform the OS installation, but yet it doesn't show up when selecting a startup disk.

5) Tried NVRAM reset (cmd+opt+R+P) but it still doesn't work.

6) Connected the SSD to my PC via a sata to usb cable to check if it works and it works correctly there.

The crazy thing is that I can erase the SSD with disk utility, I can reinstall the OS and at the end of the installation, after the reboot, it still shows the folder with the question mark during boot.

What else can I try to fix the issue?


Here's how the SSD shows up in Disk Utility:

SSD

  • Can I get a screenshot of the Federico drive to see? – bret7600 Feb 25 '17 at 22:24
  • Also, have you tried running AHT? See this article if you don't know how. – bret7600 Feb 25 '17 at 22:26
  • @bret7600 here is a screen of the Federico drive imgur.com/kVPXBlZ . In a while I will try to run AHT since I need the CD which I don't have at the moment. – jackmakee Feb 26 '17 at 10:06

You must log in to answer this question.

Browse other questions tagged .