I'm running a Rails app on my MBPr over wifi. Other computers can get to it on the LAN just fine. My iPhone (5S) can't. In fact, my iPhone can't even ping the MBP. Running tcpdump on the Mac, and a ping utility on the phone, I can see it try, but it doesn't receive the response packets.

In further fact, my iPhone can't even seem to ARP the MAC address, and resolve to an IP address. When I try to access the Mac's web application, I can see the iPhone ask to ARP the address, but it asks 4 times, apparently never receives the responses, and gives up.

I've tried turning off the cell and bluetooth radios. Both Safari and Chrome do NOT work. The phone WILL connect to a (wired) Raspberry Pi on the network. I tried plugging in my wired ethernet adapter to the MBPr, and the phone DOES connect when it is running on the wire.

So my Apple iPhone can't talk to a web application running on my Apple MBPr over wifi. It just seems... wrong. Does anyone know how I can fix this?

  • From first glance, it sounds like your wireless AP has ARP broadcast filtering enabled. What kind of AP are you using?
    – ecnepsnai
    Feb 25 '17 at 7:08
  • It's an ASUS RT-AC3200 ("Dark Knight") in AP-only mode. I've seen a setting on Ubiquity kit to prevent wireless devices from interacting with one another. Are you telling me that's how it's implemented? I can't find any setting like that on the Asus, though. Feb 25 '17 at 13:07
  • Hi David Krider, I'm wondering how you solved your problem (of your iPhone not being able to browse to your LAN server IP) as it seems like your situation resembles mine and you might have suggestions. Thanks for your help. -Ryan apple.stackexchange.com/q/284762/53510
    – Ryan
    May 25 '17 at 15:41

You must log in to answer this question.

Browse other questions tagged .