15

If an iPhone screen recording, which is 1080 x 1920 (portrait size) is edited in iMovie or Final Cut Pro, and resaved as a final video, I noticed the video will be landscape: 1920 x 1080 with black bars at left and right.

It isn't a problem if viewed on a desktop computer, but if viewed in any mobile phone, then, the left and right black bars will "push" the video to be really tiny, about 1/9 of the screen size.

Is there a way to "preserve" the video as portrait: 1080 x 1920, so that there is no black bars, and so the video will be shown on mobile phone as the original 100% screen size, instead of 1/9 of screen?

(iMovie's crop must crop it as landscape size, and Final Cut's crop can do a crop, except when "Share" as file, the file saved is landscape size again.)

I can think of one way which is to use HandBrakeCLI to do a crop, but then can it and how can it be done in iMovie / Final Cut Pro?

1
  • Funny story: some people say Final X is better than 7. Hilarious. Feb 11 at 21:15
12

I had this problem just last night, editing portrait iPhone X video in iMovie. Here’s how I got around it:

  1. In iMovie, when I added my video clips and titles and such to the timeline, I used the ‘Cropping’ edit panel to rotate them all 90° anti-clockwise. It’s weird editing video that’s lying on its side, but I got used to it.

    enter image description here

  2. After exporting from iMovie to a .mov file, I used Handbrake to transcode it to a smaller .mp4 file (which I usually do anyway). In Handbrake’s ‘Picture’ tab there’s a ‘Rotate’ filter; I used that to rotate it back 90° clockwise.

    enter image description here

    I’m sure you could do something similar on the command line with FFMPEG too.

4
  • 1
    This "picture tab" option has since been deleted
    – Andres SK
    Dec 3 '18 at 15:14
  • God damn it Handbrake. Dec 3 '18 at 15:16
  • 3
    It is now in Filters
    – Jake N
    Oct 15 '19 at 23:00
  • Thank you @JakeN ! Oct 16 '19 at 9:16
4

You can do this in QuickTime player (at least on macOS).

  1. Open video in QuickTime player
  2. In the file menu bar, select Edit then choose Rotate Left or Rotate Right
  3. File > Export

Pro tip:

If you've used iOS to record your screen, it does so with 2 audio channels - the 1st being mute. This will cause your video to NOT play audio on services like YouTube.

To get the sound back on the 1st channel, check out this blog post.

2

You can also rotate the video back to portrait in the latest version of QuickTime.

2
  • 2
    This may be the correct answer, but you really need to back it up with some instructions. The user may not have the latest version of Quicktime, whatever that version is. Please be more specific.
    – IconDaemon
    May 10 '18 at 15:17
  • I've added a more complete answer below
    – rynop
    Dec 3 '18 at 20:44
2

It can be done without third party software. I've just had this problem and found the best answer is a mix of Paul's and Max' so kudos to them.

  1. Rotate video in iMovie to edit
  2. Rotate exported video back in QuickTime Player

Rotate video in iMovie to edit

  • Import the video into project eg. by drag+drop
  • Add the video to the timeline by drag+drop (make sure it is selected)
  • Select crop video and rotate left / right with the icon Screenshot of iMovie to crop and rotate selected video in timeline

Rotate exported video back in QuickTime Player

  • QuickTime Player > Edit > Rotate Left / Right
  • Save video under new name

Screenshot of how to rotate .mov in QuickTime Player

0

I had the exact same issue. After some research I found a website that lets you upload your movie (.mov or .mp4 possibly other formats as well) and then you can crop your video to any format/dimensions (and remove black bars) and then save it back to your computer.

This is the site: https://ezgif.com/crop-video

No sign-up, login or any information is required. (I did notice a slight loss in video-quality, which I could live with in my particular case, but it is something you should be aware of.)

Happy editing!

-2

You should be able to set the resolution (0x0) in the project settings or the timeline settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .