3

My old MacBook Pro died recently (dead logic board) and I am unable to access the files on the hard drive. I used Time Machine to back it up and it was running macOS El Capitan.

My new MacBook Pro is running Sierra. I want to restore some of the files from my old Macs Time Machine to my new Mac. When I go into Time Machine I choose "Browse Other Backup Disks" and Time Machine opens.

However I cannot go "back in time" (using the arrows or the slider on the right hand side), it seem as though Time Machine is empty.

  • 1
    Are you following all the steps Apple has outlined for restoring from TM? – fsb Feb 23 '17 at 17:00
  • 1
    Not exactly because I am restoring from a different Mac, which is why I chose "Browse Other Backup Disks". The problem is that there is nothing in there. – rf_wilson Feb 23 '17 at 17:22
  • That support article states: "To copy the files, settings, and user accounts in your backup to another Mac, use Migration Assistant." and has a link to the MA support page. – fsb Feb 23 '17 at 17:40
2

Open "Migration Assistant" on the new Mac. Select the restore from Time Machine backup option. Select the time machine back up you want to restore from and restore.

  • Ok I tried the migration assistant. I can connect to the drive OK but it just says "Loading disks..." and I can't progress any further. – rf_wilson Feb 23 '17 at 18:05
  • The downside of trying to migrate after setting up the new machine, as opposed to as part of the initial setup, is you will end up with two accounts, the old & the new. Your best bet, if the new machine is still clean enough to not worry, is to wipe it & start over, then migrate as part of the first set up. – Tetsujin Feb 23 '17 at 20:32
  • Is that the only way? I only want to select certain things to restore, not the entire machine. – rf_wilson Feb 24 '17 at 7:36
  • Migration assistant has some options as to what data [though idk specifics as I've only ever used it for full migrations] – Tetsujin Feb 24 '17 at 9:31
  • Had to restore the entire TM backup, which has worked successfully. – rf_wilson Feb 27 '17 at 9:02
1

On Sierra, make sure the backup drive from which you want to restore is mounted. Open Time Machine (not Time Machine Preferences). You see a Finder-like window. Never mind the timeline of backups in the right margin that you would normally use to specify a point in time. Instead, in the left pane device list, select the backup drive.

Navigate down the hierarchy to the backup you want to use, and thence to the folder or file that you want to restore. Right-click it. From the floating menu, select "Restore to ..." A second Finder-like window appears. Navigate to the folder into which you want to restore the file. If the amount of data you're restoring is fairly small, you'll quickly hear a Boing! sound; your restore is done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .