5

I'm having trouble getting my iPhone 6s (running iOS 10.2.1) to be able to make calls and SMS texts from my Mac, running OS X Yosemite 10.10.5.

I've followed this guide online: https://support.apple.com/kb/ph18756?locale=en_US

And setup computer as per the following screenshots. (Both the iPhone and Mac only have 1 iCloud account on them which is the same on both devices)

In Facetime on OSX I get the following in preferences, which would seem to show that it's enabled.

screenshot from facetime app on osx

However, when I go to make a call I get the following error:

screenshot of error

I've double checked the settings on the iPhone under Settings > Phone > Calls on Other Devices, but when I click enable I get this error:

Any ideas where I'm going wrong?

  • 1
    What's your iCloud account email address on the iPhone? Might your issue be that the Apple IDs signing you into iCloud and FaceTime on your iPhone and Mac aren't the same (as that prompt says)? – owlswipe Feb 26 '17 at 23:07
6
+25

First, register your phone number with iMessage. It appears that it is not registered from the screenshot you provided.
See how here: https://support.apple.com/en-us/HT201349

Next, ensure your Apple ID is signed in on both devices.
Go to Settings > iCloud on your phone and check your Apple ID here: enter image description here Sorry, picture looks different on 10.3 beta

Now, check it on your Mac. Go to FaceTime > Preferences and check that it looks similar to the screenshot below: enter image description here

OK. Now let's try enabling WiFi calling again. Go to Settings > Phone > Calls on Other Devices on you iPhone, and FaceTime > Preferences on your Mac. Enable their respective allow calls options.

That should be it! Have a friend try calling you and see if a notification appears on your Mac while your phone is within its range.

If this doesn't work, comment and I'll try to help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .