1

Forgive me if this is the wrong place to ask this, but I've run out of options.

Within the past week or two my web browsers will not load anything unless it has 'https' in front of it. I am a web developer and work with Google's jQuery hosted libraries quite often, one of my sites isn't appearing properly for me because the script is loading from http rather than https -- I can't even browse to the script without https.

I know this isn't a problem with the script because I have co-workers who have it working just fine, it just seems to be a problem with my macbook. I've tried Google Chrome, Firefox and Safari all with the same results.

I've tried clearing my DNS cache using dscachutil -flushcache; sudo killall -HUP mDNSResponder; and restarting, but no luck.

Does anyone have any idea why this may be happening or what I can do to fix it? I would just reinstall Chrome, but it's happening in all browsers.

EDIT

This is a screenshot of the errors in the browser console. Not your average Cross Content error.enter image description here

  • Do you use any anti-virus or VPN? Maybe they are the cause of your error. Try to lower your security to accept unsecure connection as well. If that didn't help, you can check some help I have found on apple support (discussions.apple.com/thread/6467321?start=0&tstart=0). – jendas Feb 22 '17 at 20:54
  • Check System Preferences -> Network -> (however you connect to the internet: WiFi, Ethernet, etc.) -> Advanced... -> Proxies for any activated proxies as well. A dead HTTP proxy would neatly explain HTTPS being spared. – Merlin Feb 23 '17 at 6:18

You must log in to answer this question.

protected by Community Feb 23 '17 at 8:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .