1

When I run

rsync -avz --exclude-from=exc ~/ /Volumes/Backup/home/

I get the message

sending incremental file list
./
.DS_Store
...<snip>... (lots of files).... 
End of list of files

sent 72,625,409 bytes  received 16,434 bytes  1,793,625.75 bytes/sec
total size is 28,049,731,319  speedup is 386.14
rsync error: some files/attrs were not transferred (see previous errors)
(code 23) at main.c(1249) [sender=3.1.2]

What should I do to avoid this error message?

  • 1
    Can you add the exact command including options you are running? And the full output, not just the error message – nohillside Feb 22 '17 at 10:01
  • 2
    The important bit is that the file says see previous errors - these previous errors are the things that need to be investigated – user151019 Feb 22 '17 at 15:09
1

It seems that the only thing that was missing from my rsync run was to copy extended attributes. I ran the command again, but this time adding the option -E (which I think is specific to Macs) and the job ran with no error reported.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .