0

I have a weird thing that happened today on my Mac's disk.

I had my main partition Macintosh HD and a 150 GB Linux partition. I tried to split up the Linux partition into two smaller ones using Disk Utility (on Sierra) but it failed.

Since then, my Recovery HD popped between the Linux partition and Macintosh HD, making me unable to delete the Linux partition: Disk Utility would then try to resize Recovery HD to 150 GB if I delete the Linux partition.

disk utility

It seems Recovery HD is not hidden anymore as it should be... When I try to use cmdR at boot time it loads the Internet Necovery like if it wasn't seeing the Recovery HD partition...

diskutility

I've tried repairing all my disks from the Internet Recovery, it repaired errors, but it didn't seem to have changed anything to my poor alone Recovery HD partition.

Here is the output below of diskutil list, as you can see Recovery HD is listed as Apple_HFS instead of Apple_Boot and Macintosh HD is listed as Apple_HFS instead of Apple_CoreStorage.

diskutil list

If anybody know what's going on, I would really appreciate the help. MacOs is booting fine and it seems I can access my data, I've checked random files. It's really really weird that Macintosh HD's type is Apple_HFS instead of CoreStorage, when I run diskutil cs list I got "No CoreStorage logical volume groups found".

It seems the Disk Utility has reverted my Macintosh HD CoreStorage containing the Recovery HD to two Apple_HFS regular partitions without my consent. How do you think I could fix that ?

1

I think I fixed it.

  • First of all, you need to revert Macintosh HD into a CoreStorage using diskutil cs convert /dev/disk0s2

  • Then, reinstall MacOs on Macintosh HD using the Sierra installer for the Mac Apple Store without loosing data, creating a new Recovery HD partition.

  • Lastly, erase the old Recovery HD partition labeled Apple_HFS with Disk Utility.

  • This can't be true: diskutil cs revert ... converts a CoreStorage logical volume back to its native type. – klanomath Feb 22 '17 at 14:05
  • @klanomath Fixed, thanks ! It was diskutil cs convert – tourdetour Feb 23 '17 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .