1

If you run Apple Remote Desktop Admin you will notice Apple has recently released version 3.9.

If, as happened to me, your AppStore does not display the update to the Apple Remote Desktop Client update as well as the Apple Remote Desktop Admin upgrade, and you upgrade your Apple Remote Desktop Admin first, these bad things will happen:

  1. You will not be able to open Apple Remote Desktop Admin on your machine, because your client is not the right version.

If you run the AppStore again and pick up the ARD Client updater, you can open ARD Admin again, but

  1. You will lose the ability to send Unix commands, install packages, etc to all computers you manage that have not yet upgraded to ARD client 3.9

If you upgrade your remote clients to ARD Client 3.9 by whatever means, you will get back control of them through your ARD Admin but,

  1. The ARD Client version 3.9 is not compatible with any OS below Yosemite!

If you run clients running an OS older than Yosemite, you will only have Screen Sharing access to those clients forever more (or until a legacy patch is written).

Anyone with Apple Remote Desktop Admin 3.8.5 can still do all of the remote goodness to ARD Clients running version 3.9.

TL;DR, if you upgrade your Apple Remote Desktop Admin to version 3.9, you will have a bad time.

Can anyone suggest a workaround, other than "don't upgrade to Apple Remote Desktop Admin 3.9"?

  • Ugh... my client auto-updated, the admin tells me there's an update, AppStore just says 'Open' [infinite loop]. The update is not listed as available even though the Admin app is listed in my purchases... sheesh... so I have 3.9 client & 3.8 admin:/ – Tetsujin Feb 22 '17 at 6:52
  • Fixed, posting here in case it happens to anyone else today - deleted the admin 3.8 which then turned Open into Install & all is good again. Direct link to open it in App Store app - itunes.apple.com/app/id409907375 – Tetsujin Feb 22 '17 at 7:09
2

One thing that helps is that there is a compatibility mode in the Security Tab of the Preferences.

  • You can also screen share from admin 3.9 to client 3.8 & make the remote update its own client via its own App Store app, whilst apparently still in use, i.e. you're looking at it right now. – Tetsujin Feb 22 '17 at 7:13
1

This problem annoyed me too and there is actually a very easy fix.

  1. Open up ARD
  2. Go to Preferences
  3. Go to Security
  4. Check the box Allow communication with older clients (less secure)

After that I could send unix commands, install packages, etc to 3.8.3 and higher. I don't have anything below 3.8.3 so I couldn't test that.

1

I have successfully use ARD 3.9 to connect to OS versions as old as 10.5.8 when I upgraded this week my Apple Remote Desktop control software.

We did decide to script an update of all 10.10.0 and above machines to ensure they are updated to 10.10.5/10.11.6/10.12.3 and then applied the ARD client 3.9 update and scripted a restart of the client on each Mac that couldn't be immediately rebooted.

The problem with the client update was it often opened a dialog asking for a keychain password that often couldn't be entered. If you have problems controlling any client, restart that OS or ssh into it to reconfigure and restart (kickstart) the client agent.

/System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -restart -agent

Here is a fix to this problem:

If you login as admin on ARD and change the preferences to allow Unix commands and other settings this fixes the problem. Basically after updating to 3.9 the settings defaulted back to the factory settings.

0

There IS a way to make ARD 3.9 work between 2 machines running 3.9:

Instead of using the long username (ex. "John Smith") use the short name (ex. "johnsmith"). Fixed it for me.

You must log in to answer this question.

protected by Community Mar 7 '17 at 18:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .