For some reason, my text to speech isn't working. I don't know why it stopped working. It works when I manually click it, but when using the default hotkey alt+esc, it doesn't do anything.

I have no idea what happened. How can I fix this? I tried changing hotkeys, but the problem persists.

  • 1
    Try running Disk verify/repair. Sounds weird I know but that is what just fixed my issue. If verify doesn't tell you something is wrong then don't worry about the repair.
    – user18515
    Feb 9, 2012 at 23:47
  • 1
    I have the same issue constantly, and have to restart the computer each time to get it working again.
    – user20205
    Mar 16, 2012 at 1:16

8 Answers 8


I have found a solution that worked for me without restarting (although restarting worked before when this happened)

My problem was that both the Hot Key or the contextual menu Right-Click -> Speech -> Start Speaking did not work within any application like Chrome and Text Edit

When I went to System Preferences -> Accessibility -> Speech -> Play the button toggled to Stop as if playing but I heard no audio.

My Solution: I switched my default voice from Heather Infovox iVox HQ to Samantha then pressed the Play button.

I got audio.

Then I switched back to Heather and both Hot Key and contextual menu Right-Click -> Speech -> Start Speaking worked without quitting any apps or restarting my computer.


I found that these steps worked for me and prevented a reboot.

  1. Go into System Preferences and open Sound
  2. Select the Output tab.
  3. Switch to a different output than you are currently using.
  4. Switch back to Internal Speakers, Headphones, or whatever you typically use.
  5. Return to Accessibility, Speech and test using the Play button.

These steps worked for me and I'm assuming it might have to do with an application I have installed called Loopback that allows me to record internal audio. Hope this helps someone else out there that might be experiencing the same issue.


I had a problem using speech with the Preview app. Turns out something went screwy after adding annotations to the specific document I was looking at and all I had to do was revert it.


I have also experience this problem. I have found today that shutting Google Chrome and restarting it cures the problem.

Update. This happened again & restarting google chrome did not fix it. I ended up closing all my open programs & finder windows & restarting finder then it worked again. I will update this again next time it fails & try to identify the specific action that fixes it or causes it.

I have a hunch it may be connected with System Preferences, finder windows or Monitor.


Sometimes you just need to reboot your machine. Mine sometimes just stops working. A reboot takes care of it.


Thanks geekinit! I used your idea but in less steps.

  1. Hold option and click the speaker(sound/Volume) icon on the top menu bar
  2. Change to different output device
  3. Use same technique to switch back to internal speakers or headphones (etc...)

This fixed the problem for me without having to go into system preferences.


Maybe try deleting


Make a copy of it first in case it goes bad. Also, just be careful because it will remove your shortcuts.


For me, the fix was:

  1. go to System Preferences -> Accessibility -> Speech
  2. change System Voice to something other than what is currently used, such as Samantha. Test it by clicking Play.
  3. for me, if I select some text and press the keyboard shortcut (option+esc), it works now.
  4. switch back to the voice you want, such as Alex. It still works with the keyboard shortcut.

So by toggling the voice, it reset something which made the bug goes away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .