1

Recently I made a hasty mistake in forcing a shutdown when it was becoming unresponsive. Previously I've been able to boot the system with no problems by starting in single user mode (to bypass the gray progress bar (which disappears after loading partially) and spinning wheel that stays indefinitely). However, now when starting up the system, it appears that pressed keys aren't recognized.

I've tried resetting the SMC (by unplugging the power source and battery and holding down the power button for 5 seconds), but that appeared not to help.

Is there another way to get to single-user mode or reset the NVRAM (such as by opening and adjusting something in the MacBook)?

EDIT: I attempted diagnostics based on comments below by trying to boot into Verbose mode and holding Option to bring up the bootloader, but nothing worked.

  • Command-Option-P-R doesn't work? Now, the fact that you have to boot to single mode to boot your Mac is concerning...why didn't you address the problem earlier? – Allan Feb 21 '17 at 1:35
  • Command-Option-P-R didn't work. It didn't seem to be much of a problem earlier, as running fsck functions from single-user mode appeared to work well (I only had to do this a couple times) and everything was working when running the system. – Phillip Feb 21 '17 at 1:37
  • 1
    Try holding Cmd-V (Verbose Mode) and see what get's output to the console. Look for error messages. Also, do you have your original install disks to run Apple Hardware Test? – Allan Feb 21 '17 at 1:53
  • 1
    Just for giggles, try holding Option to see if it brings up your boot loader. If it dosen't your keyboard may be hosed; try an external one. If that doesn't work, it's time to start looking at repair shops because there's nothing that can be adjusted. If you can't boot to Verbose mode or to the boot loader, replacing a drive won't help. – Allan Feb 21 '17 at 2:08
  • 1
    Thanks. I take it for granted that Alt = Option but I am glad you were able to get your situation addressed. If you still need to fix your constantly having to boot to Safe Mode, that can be another question. – Allan Mar 8 '17 at 12:30
1

Your keyboard may not be functioning properly.

If pressing ⌘ CommandV doesn't get you into verbose mode but you can can no longer get into Safe Mode (⌘ CommandS) there may be something wrong with the keyboard.

Try an external USB keyboard to issue the ⌘ Command⌥ OptionPR to reset the NVRAM. (Alt = Option)

That should allow you to reset your NVRAM. At this point you should test out the built-in keyboard and if it still isn't working, it's time to look at getting it replaced.

  • For the record (if this may help someone), the keyboard apparently stopped working due to a battery that began bulging. It had been kept out, but I think it was recently placed back in because it was thought to have fixed a backlight issue I was having. – Phillip Mar 9 '17 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .