Why does Spotlight want to search Google for Chrome rather than launch the app Chrome?

For some reason, searching for Chrome in Spotlight yields numerous suggestions (a Google search for "Chrome", the definition of "chrome", the Wikipedia entry for "Google Chrome") but none of them is the Chrome app on my computer—why doesn't the app show up?




Spotlight Chrome

  • Here's a gif of me searching Spotlight for Chrome (and it working): openload.co/stream/…
    – owlswipe
    Feb 20 '17 at 22:05
  • Let me know if my answer helps or not! If it doesn't I'd be happy to help more :D.
    – owlswipe
    Feb 21 '17 at 15:16
  • after all these years, this bug is still repeating
    – hihell
    Feb 2 '21 at 21:10

Deleting Spotlight's index of your files and reinitializing it should allow it to find your apps in the Applications folder.

1. Turn off spotlight:

sudo mdutil -a -i off

2. Unload its metadata plist:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

3. Load its metadata plist:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

4. Turn on Spotlight again:

sudo mdutil -a -i on
  • This worked. 👍🏼 Marking as the Answer.
    – GN.
    Feb 24 '17 at 2:39
  • @GN. Nice! Happy to help.
    – owlswipe
    Feb 24 '17 at 3:23
  • 1
    Sigh... /System/Library/LaunchDaemons/com.apple.metadata.mds.plist: Operation not permitted while System Integrity Protection is engaged Might want to mention that this can be an issue in your answer.
    – JVC
    Mar 26 '18 at 15:55
  • I got the same error as @JonathanvanClute however turning Spotlight on and off with those commands was enough to make it index again, and solve my problem (VMware in this case).
    – toast
    Aug 22 '18 at 2:08
  • 2
    Doing only steps 1 and 4 worked for me. (As mentioned by others, step 2 requires System Integrity Protection to be turned off.) Oct 2 '18 at 20:16

Make sure the "Applications" option is selected in System Preferences >> Spotlight >> Search Results:

enter image description here

If Google Chrome is installed (and in the Applications folder) pressing Command⌘+Spacebar and typing "chrome" will make Spotlight display the application as the top hit:

enter image description here

  • @owlswipe I danced a jig the day I found out Preview.app has arrow, text and shape annotations! :D
    – MmmHmm
    Feb 20 '17 at 23:55
  • ohh yeah! And the just taking a screenshot of the window with a shadow is on point.
    – owlswipe
    Feb 21 '17 at 3:37
  • 1
    @owlswipe SRS BSNS!!! Windows has their "snipping tool" and "alt prnt scrn" and all, but cmd+shift+3 & 4 are so sublimely superior - especially cmd+shift+4, spacebar. (I just kissed my mac)
    – MmmHmm
    Feb 21 '17 at 3:44
  • also the QuickTimePlayer (& iMovie) screen capture with select area is supremely amazing (I also recently discovered the SoundFlower.kext to MIDI route system audio so QT can grab that too...) and with a little FFMPEG conversion to .gif - it's a whole new world of lolcats!
    – MmmHmm
    Feb 21 '17 at 3:48
  • I would fire back with tricks of my own but when I hear FFMPEG I know I've been way outclassed :))
    – owlswipe
    Feb 21 '17 at 4:27

I know an an answer has already been accepted, but my problem was different so adding my solution here in case others are in the same situation.

My problem was the app in question being incorrectly named in the 'Name & Extension' settings for the file even though Finder showed the name correctly (Right-click on app -> Get info -> Name & Extension) - I don't know how that happened (possibly my kid playing with my laptop) but if the name in the textbox isn't the same as the app name, Spotlight, or Alfred in my case, won't be able to find it.

enter image description here enter image description here

Just enter the correct app name with .app extension in the textbox and you should be good to go.

  • If your problem was different, why are you posting the answer to it here? Search Ask Different to see if the question was already asked and post it there. If not, feel free to ask a new question and post the answer.
    – Allan
    Feb 5 '18 at 13:55
  • @Allan did you read my answer in full? Because although the cause to my problem may have been different, it was still the same 'problem' of "Spotlight can't find Google Chrome app" - no reason why I should pollute the database with a similar problem asked differently. People asking the same question will read a different answer if the accepted answer doesn't work for them, and they will find their solution in the other one ;)
    – mavili
    Feb 7 '18 at 20:19
  • Read your first paragraph.....
    – Allan
    Feb 7 '18 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .