3

When connecting to a new Macbook Pro 2016, running Sierra v10.12.3, it doesn't ask me to type the 6 digits to pair it properly. It also shows up in the bluetooth list with the bluetooth icon, rather than a keyboard icon like other keyboards. And in keyboard settings, I am unable to adjust the modifier keys, as I can with other keyboards.

Any ideas how to fix this?

  • Sorry, good point, updated. – Travis Reeder Feb 20 '17 at 19:56
  • @TravisR, please Option-click the bluetooth icon in your menu bar, it should provide more detail about the keyboard and how it is being registered by the Mac which could be helpful when figuring out the problem (feel free to omit the actual BT address as this is unneccesary info). Another point, does the keyboard have a USB A/micro port on it (perhaps for charging)? If it does and the port can also read data it may be causing the keyboard to be recognized as a data transfer device rather than a keyboard. Finally when you connected it did you get a "This keyboard is unrecognized" dialogue? – Alison E.E. Feb 20 '17 at 20:45
3

It appears that the keyboard is not compatible with macOS. The Surface Ergonomic Keyboard doesn't list compatibility with any OS other than Windows 10 and specifically, the Surface line of products. Basically, there is no macOS driver for this particular keyboard.

enter image description here

This is unlike their more generic Sculpt Ergonomic Keyboard which specifically lists alternate OSes including macOS and Android (though with limited functionality).

3

I use my surface ergonomic keyboard with macOS. The only thing I found tricky was that you need to hit the enter key after typing in the code.

3

macOS Sierra does not fully recognize the Microsoft Surface Ergonomic Keyboard as a keyboard, but a workaround exists.

  1. Install Karabiner Elements. It lets you intercept and remap keyboard input.
  2. Launch Karabiner Elements and go to the Devices tab and uncheck everything but "Ergonomic Keyboard" so that Karabiner does not swap keys with any other keyboards attached to your computer.
  3. Switch to the "Simple Modifications Keys" tab. Click the "add item" button. Remap "left_command" to "left_option" and "left_option" to "left_command". Then do the same for "right" command/option keys.
  • 1
    I am experiencing that Karabiner Elements, in all versions up to and including 11.0.0, "eats" the initial character after I stop typing for a second or two. Is K-E still the best we can do about the Surface with macOS? – mdaniel Sep 21 '17 at 7:31
0

On my iMac running High Sierra, IntelliType 8.2 suddenly stopped recognizing my MSFT Ergonomic 4000 keyboard. One day it was working fine, not the next. After attempting everything, including reinstalling the OS, I finally called Apple Support (MSFT Support had been useless).

I was fortunate to get a great guy, Andrew B in North Carolina. He figured out what we had to do. The culprit was Apple's "System Integrity" patch, which they added to their OS starting with El Capitan. The solution was to turn it off. Here's how:

1- Launch Terminal and enter: csrutil disable Then hit Enter.

2- Restart

3- Reinstall your keyboard/mouse driver (must do this!)

4- Restart, and all should be AOK!

Andrew recommends turning System Integrity back on following Steps 1 & 2, using "... enable" in Terminal. I elected to leave it off to avoid similar future issues.

0

I use Mac running High Sierra as of this writing, and saw an issue with Mac not getting all the keystrokes and also, my mouse would jump around. I have two offices, exact same setup. This does not happen at one, but does from my home office.

I noticed the difference was that at home, I had an external HDD plugged in also. This is the only variation of the two setups. Once I removed this, and plugged my dongle back in, the issue went away. (I have tried to remove dongle, and plug back in, also move closer to my keyboard and mouse (was 14 inches away).

It seems like the issue may be related to the usb ports being under powered or over utilized. Anyway, unplugging my external drive fixed the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .