My Mac Mini (Mac Mini 3,1 at OS 10.11.6) shows this after a "successful" run of First Aid from Disk Utility on the internal HD (i.e. not just the main volume, the entire HD) "Problems were found with the partition map which might prevent booting." I have run First Aid from regular partition and recovery partition. Subsequent runs of First Aid don't show the "Problems" message, but if I run Disk Util after a reboot, "Problems were found..." message reappears. Internal HD is a Crucial SSD. Disk Util run on main volume shows no such messages.

I very recently erased and installed original OS on the internal HD using the OE install DVD (10.5, hit C key at boot), then upgraded to 10.6 using OE DVD, then to 10.11.6 using App Store. Then I recovered from a Time Machine backup saved on an external HD.

I worry this "Problems were found..." message is a time bomb. I am surprised this problem persists after I erased the HD and did a clean install of the OS.


  • What does a recurrent "Problems were found with the partition map which might prevent booting" message mean practically?

  • Should I run other tests on my SSD and/or replace it? What are those tests?

Overall, Mac works fine except I can't run AHT at boot (not from OE install DVD #2 with D key, nor using Option key to select that DVD or to select AHT on a theoretically bootable USB flash drive with AHT). These failed boot attempts go to gray screen of death, but Mini boots up fine after powering down.

Background: Mini had RAM problems, but couldn't run AHT from original install disk #2 (Leopard 10.5), nor from USB flash drive (Previously discussed here: AHT problems). I tried a PRAM reset, which corrupted my main HD, but I managed to erase and do a clean install from OE disk (10.5) and recover Time Machine backup from an external HD (Discussed here: PRAM crisis)

  • Perhaps related: Occasionally, the active window (say, Safari right now) will gray out for a moment without any action by me, like the computer is going into Neutral in a stick car. It's weird and I've never noticed it before recently. Doesn't happen very often. Maybe every five minutes, max.
    – ScotttDC
    Commented Feb 20, 2017 at 18:13
  • Surprisingly helpful Apple Tech Support suggests I try remote Hardware Test (Option+D at startup, which based on previous research I'm skeptical will work)... then do an OS install from Recovery Mode, which would rule out any errors caused by installing 10.5 and 10.6 from DVDs, then updating to 10.11 from App Store. I'll try that.
    – ScotttDC
    Commented Feb 21, 2017 at 3:25

1 Answer 1


I created a bootable external HD running 10.11.6 and I can boot from it. I also erased my internal and reinstalled 10.11.6 on my internal SSD. I booted to the external after selecting it as Startup Disk in Sys Prefs, and ran Disk Utility on the internal. Afterward, I no longer get the message "Problems were found with the partition map which might prevent booting." Phenomenon of Mac momentarily "going into neutral" described above also appears resolved (based on 30 minutes of use, anyway). Soon I will boot to external and rerun Disk Util to recheck for errors on internal. But so far, seems good.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .