1

I have successfully dual booted both Window and Mac OS as well as Kali and Mac OS. The problem is installing Kali once I have dual boot Windows and Mac OS. I have tried several tutorials, and the one that got me the furthest was here. Once I had windows and Mac OS dual booted, from within Windows I shrunk the Windows partition to 128gb, and created a 32gb for partition for Kali, a 32gb one for swap, and 32gb for a shared file folder between all three OSs. I then tried installing Kali with the GRUB boot loader. No errors occurred, then when booting with rEFInd I selected the Linux partition, only to receive an error saying "missing operating system." I then deleted all of the partitions, reinstalled Windows and then tried installing Kali without the GRUB boot loader. This did not work any better. Windows still gave the 0xc000000e with the "preparing to repair" message, and Kali still said it was missing the OS. I know this doesn't pertain entirely to Apple, as it involves Linux and Windows, but has anyone successfully done this before?

This is my laptop. It has a 500gb SSD, and 16gb of RAM.

2

I sugest the easiest way is to instal Mac and windows as you have done before make the partition etc then when you go to install Grub there is an option where to install it. install to the partition where the linux installation is (take note during partitioning the location) this way the boot partition doesn't get edited and often it cant be on new systems except by the host OS. then make a bootable usb with supergrub2 to boot linux this way when osx updates or anything else decides to write to EFI your ok. this still gives you the option to direct refind or whatever bootmanager to grub

  • Thank you. I have not yet done the supergroup2 thing, but I now can boot into Windows, Kali, and MacOS. The problem is now that when I boot Windows I get the 0xc000000e error. I am unsure about other or not to do the command fixes here. As that was for Ubuntu and not Kali. – Thoughtyness Feb 22 '17 at 23:42
  • That worked, and I still wanted to do the shared folder so I used the aforementioned tutorial. Then tried [installing](bit.ly/2lrYYia) ntfs-3g on macOS. Once I did that I rebooted and both macOS and Windows were fine, but Kali booted into a text only mode. Startx didn't work. I tried [this](bit.ly/2lrVsV8), but when running sudo apt-get install chkconfig I get dpkg was interrupted, you must manually run sudo dpkg --configure -a. Running that doesn't fix it. I then tried sudo apt-get install -f, only to receive the same error. I have a USB to Ethernet adapter for my internet. – Thoughtyness Feb 23 '17 at 4:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .