2

My apartment building provides free wifi internet. I have a local wifi network with multiple IOT devices, so I need to be able to serve the building's wifi across my local wifi just as I would if I was accessing the internet by cable modem. I own two wifi routers: A current gen Apple Express and an old Airport Extreme.

I set up the Airport Express to connect to my building's wifi. I connected it by ethernet to my Airport Extreme, which sees it as if it were a modem.

It works, but, I get a Double NAT error.

A: How do I fix the Double NAT, and B: How do I make sure my local network is secure?

2
  • Are you sure it's Double NAT and not just the building having AP Isolation on?
    – tyteen4a03
    Commented Feb 19, 2017 at 23:16
  • Airport Utility says its status is Double NAT.
    – 2oh1
    Commented Feb 20, 2017 at 2:39

3 Answers 3

3

you need to put the base station into "Bridge Mode" so that it does not think it is on a separate network and merely participates in your building's WiFI.

Open up the Airport utility, select the Airport in question, Click the Network tab, then choose "Off (Bridge mode)" from the Router menu.

When you apply those changes the Airport will need to restart and you should be good to go.

1
  • I think it would be a preferable way while technically double NAT is perfectly good and doesn't affect Time Machine backups or internet connection. If you have few Time Capsules or a few network devices which are double NAT'ed then your networks become isolated. For example no remote desktop, no file sharing or other device to device data will be possible at your house. It adds extra complexity and in most of the cases it's not needed so Bridge Mode is the way.
    – laimison
    Commented Dec 2, 2019 at 13:26
1

There's nothing really wrong with double-NAT, I have it here because of a combined phone and internet router. The WAN connection goes to a 192.168.0 LAN with my Airport as the sole client. Airport provides a 192.168.1 network to everything else.

The phone company's router is set up to provide a static address to the Airport and forward all ports (DMZ) to it.

You can turn off the warning (and yellow light) in Airport Utility.

I run OSX Server on my desktop, I have websites, file sharing, VPN, calendar, contacts, and remote-control cameras all running behind the double-NAT, accessible from the internet, and I have no problems whatsoever.

0

This worked for me (OSX 10.11):

System Preferences > Network > (in left column, select the "service" through which you get your internet access) > Advanced > Configure IPv6 > Link-local only

2
  • That doesn't change anything though. In my Airport Extreme router, I still see "Status: Double NAT"
    – 2oh1
    Commented Oct 27, 2017 at 18:47
  • I don't think that this fixes the double nat issue.
    – Gray
    Commented Jan 4, 2022 at 17:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .