0

swift auth yields the error:

error: unable to invoke subcommand: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swift-auth (No such file or directory)

when I brew install it it does the same thing. how can I swift auth again?

1

Xcode is an easy reinstall. Have you tried deleting it and going back to the Mac App Store to reinstall it?

If you’re developing on a beta version, be sure to list that in the body and you can do the same re-download and reinstall.

If you’re comfortable with the command line:

xcode-select -p

Check that your path is correct, and perhaps reset the tools path (which swift-auth ) and call for the command line tools to be installed if needed:

sudo xcode-select -r
Xcode-select —-install

The above commands will be substantially faster and more surgical to reinstall, but if you are missing one Xcode tool, you might need the whole app again depending on what caused the error in the first place.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .