1

For years, I’ve disabled my Mac’s caps lock key (because I only ever hit it by accident) in System Preferences > Keyboard > Modifier Keys.

Recently, I did a clean install of macOS Sierra on my 2014 MacBook Pro. Since then, my disabling of the caps lock key doesn’t seem to persist after reboots.

I found an apparent report of the same issue on Apple’s forum, and there are a few similar questions about previous versions of macOS:

But I don’t see an actual identified cause anywhere, nor a workaround.

Is this a bug? If so, how can I fix it?

If not, is there any way I can get the old, persistent behaviour?

1

It could be a problem with file permissions. Try this command in the Terminal (a built-in system tool):

chmod -RN ~/Library/

It resets permissions for your user Library folder. When the command is done executing, reboot. Change the setting and then reboot again, and see if the setting persists.

If it didn't work, then try this command:

chmod -RN /Library/

Yes, there is a difference: it resets permissions for the system’s Library folder.

Then reboot and change the setting as mentioned before, and see if it persists now.

  • “It could be a problem with file permissions” — could it? How? – Paul D. Waite Feb 16 '17 at 17:39
  • Restoring from backup or doing software updates/install can give trouble with permissions . Unless you're a nerd that do give special permissions to each file, these commands shouldn't give any complications. – Harcker Feb 16 '17 at 17:50
  • I wiped my Mac, installed Sierra on it, and manually copied over my files. I didn’t use any automated restore-from-backup procedure. – Paul D. Waite Feb 16 '17 at 19:09
  • That could be the problem too, cause the files were copied over, some of them could still have the permissions of the older install... – Harcker Feb 16 '17 at 19:12
  • 1
    Is there other settings that don't save? – Harcker Feb 16 '17 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .