1

I'm required to change my school Gmail password every year. I recently did so, and it seems to work just fine for accessing Gmail with a web browser. It also works fine in the Mail app in iOS (I was asked to enter the new password, but it accepted it just fine). However, in the Mail app on macOS, I've run into some issues. It shows a "Login Failed" message on the top right of the window as well as the telltale lightning bolt "offline" icon to the right of the mail in the left sidebar. I totally expected to see both of those, since Mail is trying to access the account using the old password. But I can't get past that. If I click on either of those, it opens a dropdown/popup where I can enter the password: Gmail Password Issues #1 That's all good. After I enter the password, though, I see a "loading" animation (a spinning-type one) for a brief second and then just blank gray in the window: Gmail Password Issues #2 The same thing happens if I try to do this in the Internet Accounts section of System Preferences.

Does anyone know why this is happening and how I can resolve it?

0
2

I had this issue recently. There are some answers here, but what worked for me was I had to sign out of my iCloud account first. Add/Update the Google password (should now work) then sign back into iCloud.

3
  • It worked! But I have to say: that's a very strange bug. Also, I accidentally did it out of order - I signed out of and back into iCloud before updating the Gmail password - but it still worked just fine. I was additionally worried that signing out of iCloud would cause me to lose something, but it at least looks like everything was re-downloaded and such after I signed back in. Anyway, thanks for your help! Feb 16 '17 at 6:52
  • Also, related to the link that you shared, it seems like there are actually multiple different solutions (there are also links within your linked page to other questions about the exact same problem). Interesting! Feb 16 '17 at 7:01
  • this didn't work for me. i had switch my default web browser from Chrome to Safari (System Preferences > General > Default web browser), then the window will properly redirect to the log in screen instead of being blank Jan 2 at 23:07

Not the answer you're looking for? Browse other questions tagged .