0

I am using a MacBook air and I am unable to go to websites unless I specify http or https

My version is 10.10.5

Websites which automatically have https work like youtube.com and netflix.com

cnn.com does not work.

  • What web browser are you using? – Jackson1442 Feb 15 '17 at 5:34
  • Chrome but it happens on all browsers – H P Feb 15 '17 at 5:56
  • 1
    does it do this on other computers on your network? Does it do this on other networks? – Jackson1442 Feb 15 '17 at 5:57
  • Could you please elaborate? If it is happening to all macs, it may be an issue with your router. – Jackson1442 Feb 16 '17 at 6:17
  • Not. it is just happening on my MAC. And it has happened in all networks and in different countries as well. Something with the DNS setting but not sure – H P Feb 16 '17 at 14:26
1

This might be because of your DNS. Simply try changing the DNS and it should work. Open Network settings and try changing your present DNS to Google Public DNS and it should get fixed.

Google Public DNS :

  • 8.8.8.8
  • 8.8.4.4
  • Hi That still did not work. Should I add IPV6 options too? – H P Feb 20 '17 at 5:07
  • @HP No. Don't change them – leovarmak Feb 24 '17 at 3:08
  • I just have the above two entries and it is still not working. – H P Feb 25 '17 at 18:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .