4

Currently in iOS there is a feature where you click on one link (say link to a Youtube video) and the corresponding App will open to handle the request (the Youtube app will open to play the video). This is called App Link.

However in my case, all the link are broken all of a sudden after a reboot. Clicking the Youtube link that would have taken me to the Youtube app now just opens the webpage in Safari. Same thing happens to any other links, for example, Quora, Amazon, Reddit, etc.

There's no way of re-enbling the open-in-the-app behavior, because

  1. There is no "Open in the xxx app" banner on the top of page anymore.
  2. Pressing a holding a link in the Note will no longer reveal the option to open the link in an app.

There're currently 3 fixes:

  1. Reinstall the App;
  2. Restore all settings;
  3. Wipe the iPhone and restore.

All of these solution are not ideals and very time consuming, I have to remove and reinstall every App with this app link feature to fix the problem. Also this problem happened to my several times.

Anyway I can fixed these in a easy way?

Tried and not working method:

  1. The fix for broken Universal link incident on iOS9;
  2. Reboot, regular one or one by holding power and home button.
  • Weird issue! Have you tried some of the soft resets found in Settings -> General -> Reset? They've helped me with similar problems in the past. – owlswipe Feb 15 '17 at 0:32
  • Also try doing a soft reset pressing and holding home button and lock button several seconds until apple logo shows up. If the problem persists try to do a full reset and recover from iCloud and if that doesn't help neither, do the full reset again and start from scratch. Seems like you've got a problem sitting really deep - did you have those issues in older iOS versions, too? – pallox Feb 15 '17 at 12:47
  • @owlswipe soft reset doesn't help. – toaruScar Feb 15 '17 at 17:04
  • @pallox yes I have tried hold power hand home button, it does not help. Wipe and restore will work, but it's not favorable because of the time it takes and the fact that it happened to me multiple times. – toaruScar Feb 15 '17 at 17:06
  • @pallox this only appears on iOS 10. I am trying to avoid starting from scratch, because the data I have dates back to iOS4 era and have some meaning to me. – toaruScar Feb 15 '17 at 17:17

You must log in to answer this question.

Browse other questions tagged .