8

Can't believe that I have to ask this question, but...

How to I disable the screen saver on my 2014 MacBook Pro, running MacOS Sierra 10.12?

I have a need occasionally to keep the screen display on, but I might not use it for 20 minutes at a time. I want to disable the screen saver, but the button to adjust the time (I presume it has a 'None' option) is disabled.

enter image description here

How can I enable that dropdown, in order to change the 'Start after' time? Or is there somewhere else I should change it?

I know that I can use hot corners to disable screen saver, but that's too hacky - if I forget to put the cursor in the corner, it doesn't do it, and I only know when the screen saver comes on - which is frustrating.

10

Check out this discussion: Screensaver "start time" option grayed out

  • The system administrator has probably set the screensaver timeout in a user profile. You can't change it without removing the profile, which will probably cause you to lose network access.

  • Check if you have a profile (overriding your personal settings) by Apple > System Preferences > Profiles

screenshot of system preferences ("Profiles" is in the bottom right)

  • if you have a profile, one of these files has its settings: ~/Library/Preferences/ByHost/ look for a file with a long name that begins "com.apple.screensaver". There may be two such files. Move the one without the word "slideshow" in the name to the Trash.

It most probably applies to your problem too...

  • 2
    Welcome to AskDifferent! Please summarize the most important information from the link in your answer. Hyperlinks change and we are looking for standalone answers. – n1000 Feb 13 '17 at 20:14
  • come'on at least I am trying to solve other people's problems... instead of downvoting answers from people trying to help. The comment would have been enough, no need to downvote an intent to help other people. This is not very encouraging for the future ;-) – Canelo Digital Feb 13 '17 at 20:32
  • I did not downvote your answer – n1000 Feb 13 '17 at 20:41
  • 2
    Thank you! Found that corporate had put a setting in the profile forcing a screenscaver timeout; I can take it up with them now. – PeteCon Feb 13 '17 at 20:41
  • 5
    Including all the relevant info in an answer, and not just providing a link, is expected for all answers on this site according to How to Answer in the Help Center. Answers that are link-only are going to be down-voted because they're incomplete. We're happy you're answering questions, please continue to do so, just follow the Help Center guidelines when answering and you'll get more up votes than down votes. – fsb Feb 13 '17 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .