4

I want to use the fn key on my keyboard as a trigger for an AppleScript (.scpt file) via FastScripts.

The reason that I want to do this is because the fn key is occupying coveted real estate on the keyboard, and I don't think I've once used a fn key shortcut in my life.

I installed Karabiner and went through every option under the "Change Fn key" and "Fn To All Modifiers Mode" categories individually, to see if FastScripts would be able to pick up on me pressing the fn key and thus allow me to assign the fn key as a script shortcut.

  • FastScripts was able to pick up my keypress when the "Fn to F14" option in Karabiner was selected. But, F14 is apparently already in use, because when I pressed the key, my screen brightness setting decreased a notch, which is obviously undesirable.

  • FastScripts was also able to pick up my keypress when the "Fn 2x to F19" option in Karabiner was selected. But, this obviously requires me to press the fn key, twice in order to start the script. This is also undesirable.

These were the only two Karabiner options that FastScripts was able to perceive.

I am not particularly wedded to using any application in particular (e.g., Karabiner) to accomplish this.

OS X El Capitan, version 10.11.6.

1

You can stop F14 from changing the brightness in System Preferences.

Go to System Preferences > Keyboard > Shortcuts > Display, and untick "Decrease display brightness":

System Preferences window

Any integrated brightness keys on your keyboard will continue to function.

  • I do not have a "Display" category in System Preferences → Keyboard → Shortcuts. Here is a screen shot. – rubik's sphere Feb 13 '17 at 18:49
  • That's odd - it's an old post, but try giving this a shot: xlr8yourmac.com/tips/remap_function_keys.html – Faiz Saleem Feb 13 '17 at 19:40
  • I connected an Apple Wireless Bluetooth Keyboard to my Macbook, and then the "Display" category did show up. This leads me to conclude that this category is only shown when an external keyboard is connected to the computer. I was then able to deselect the F14 shortcut, as you demonstrated in your answer. The "Display" category disappeared when I turned off the wireless keyboard, but, fortunately, the off setting for the F14 shortcut is saved. – rubik's sphere Feb 13 '17 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .