1

I recently tried to upgrade from OS 10.6.8 to El Capitan OS on my ~'09 MacBook (using a install file downloaded from the app store) and, for whatever reason, it the installation failed. When I reboot the computer after the receiving the failure notice, I am unable to select my original HD as a boot drive. By default, the El Capitan installation is selected, but I am also able to boot from the Recovery partition.

This is the error I receive: "The OS X Installation couldn't be completed. If you continue having a problem installing OS X, the installation log may help you diagnose the problem. To save the log, click Save Log.

To start installing OS X again, click Restart.

To start up your computer using a different disk, coose Startup Disk from the Utilities menu."

Every time I run the installer, it fails.

When I boot from the recovery partition, I am able to view my "Macintosh HD" drive in the terminal using the "df" command, and by listing the files in "/Volumes". However when I open up the "Startup disk" utility in the apple menu, there aren't any drives available to select, so I can't reboot from my HD.

Things I have tried:

  • setting the "Macintosh HD" drive and associated drive in /dev as the startup drive using bless. I was able to confirm that that drive was selected as the startup drive using some command (I can't remember off the top of my head which command). When I rebooted, it went directly to the installer

  • unmounting the installer partition

  • deleting the "Install OS X El Capitan.app" folder located in "/" (rm -rf "/Install OS X El Capitan.app"). It wouldn't let me do it. For each file, it says "Read-only file system"

  • running the disk utility "First Aid" on both the "Macintosh HD" partition and the actual disk

  • create an additional 1.5 GB partition on the disk. I'm not sure what that's supposed to do, but I read online somewhere that it would fix it...

  • reinstalled the OS using the "Reinstall OS X" utility from the recovery partition. I got the same error.

I have 26 GB available on my disk, so that shouldn't be a problem. I think El Capitan needs like 10 GB. I think I have 2 GB of RAM, which is the minimum requirement (not sure how to check that in the terminal).

I do not have the hard drive backed up, and I'd rather not wipe the drive if possible. If push comes to shove, I can copy all my files to an external drive using the terminal in recovery mode, but I'm hoping there's an easier fix out there.

  • If you run the reinstallation again, it might let you press Command-L to view the log as it installs. You can then see at what time the installation fails – Rajiv Feb 13 '17 at 2:10
  • If you have the software I would try a 3rd party disk repair utility (Diskwarrior and the like) as Disk Utility.app doesn't fix everything. Otherwise your next choice may be backup, reformat and THEN install as something in the disk partition map may be hosed. – Steve Chambers Feb 14 '17 at 0:42
  • Thanks for the replies. Is there something I should be looking for in the log files? The installation ran for about an hour before it stopped. I don't have any 3rd party disk repair software. Is there a way to see if the partition map is damaged using the app utilities? – newothegreat Feb 14 '17 at 2:25

You must log in to answer this question.

Browse other questions tagged .