1

I was having problems booting to Apple Hardware Test and decided to reset the PRAM. Big mistake; now it won't boot at all. It's a Mac Mini 3,1 (Early 2009) running El Capitan. PRAM reset chimed twice. Now it chimes after power button hit but then just stays at a gray screen forever. Using a wired keyboard plugged directly to USB port.

I have tried everything I can think of: Reset PRAM again; SMC reset; Safe Mode (Shift key, pre-boot); Verbose mode (Cmd+V); tried to boot to install disk #2 (10.5 DVD, with utilities, currently loaded in drive) for Recovery mode using Cmd+R; replaced PRAM battery; AHT from disk (D key); Choose boot drive (Option key); reseated RAM chip in a different slot; unplugged everything overnight then tried again this morning.

All fail. Light comes on, I get dong chime, drive spins for a bit, but then just a gray screen. Any ideas? Thanks a lot. Kind of desperate here.

[I am aware I should probably buy a new Mac but I'd like to make this one work.]

  • I should probably add that my internal HD is a Crucial SSD. Never given me any problems. – ScotttDC Feb 13 '17 at 2:23
  • And startup commands for Single-user mode also fail. – ScotttDC Feb 13 '17 at 2:33
  • Booted with no ram chip installed to see if there was any life at all. Beeped once every 4-5 seconds. – ScotttDC Feb 13 '17 at 3:10
  • Got the mini to boot to Target mode, successfully connected via FireWire with older G4 PowerBook. PB sees the mini's drive (and the install disk in the optical drive), attempting to repair the Mini's HD from the PB. – ScotttDC Feb 13 '17 at 15:11
  • Verify and Repair from PB found no problems with the Mini's internal HD. – ScotttDC Feb 13 '17 at 15:22
0

I fixed it. Hail Mary solution was to unscrew and take the cover off the SuperDrive, manually remove Leopard install disk #2, lay install Leopard disk #1 in there (much easier than expected), then power on with C key. (I think it was the second try, I believe I hit and held C before hitting power.) Then I got the Apple logo and was asked if I wanted to install Leopard. I erased the drive and installed Leopard. Booted perfectly after install. Now I'm installing Snow Leopard (from upgrade DVD, which I still had), and afterward I'll install El Capitan by download (the OS I had before).

If that didn't work, I was going to buy a new Mini tomorrow morning. It was the last thing I could think of.

So apparently the PRAM reset screwed up my HD real bad. Before the PRAM reset I had very recently run disk repair from DVD and from the boot HD and repaired permissions in Terminal (like within 12 hours before).

If anyone cares to advise, what's the best way to install a Time Machine backup from my external HD after I install El Capitan? Migration Asst? Recovery Mode? Thanks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .