1

I got this computer from someone else and instead of reformatting I simply created a new user. I created a new user account, made it admin, and attempted to delete the old one. The old user was deleted from my new users' Users and Groups GUI. The language was set to english. But it didn't exactly "disappear".

Now when I restart, I am presented with the mac osx login screen which shows the original user's account (that was deleted) to select to login and it's in spanish. My account is not present. I must login to that old account, which then takes me to a new mac osx account selection screen. This new account selection only shows my new user account. I log in, and I'm in my new user account. There's new record of the old account in Users and Groups.

Nothing in my current account speaks of that old user...nothing in /Users speaks of the old user...what gives? Where is the record of that old deleted user, and why must I login twice? I must remember that old password which is kinda bogus.

UPDATE - Solved!

FileVault was the culprit. Decrypting all files by disabling filevault in my user account allowed me to get rid of the double login screen.

The steps to do this are: disable FileVault from system preferences, restart computer, then the files will start to decrypt (takes a long time). I did not realize FileVault was enabled, but it likely had been by the previous owner.

One tip for others is make sure you have set up a root username and password incase you run into any issues where you need root access. You can do this in the terminal by typing sudo passwd root and setting your root password.

Thanks to the commenters for helping figure it out.

  • Added more info to my question. I didn't enable FileVault. – Danny Feb 12 '17 at 18:17
  • Was FileVault enabled before you got the computer? That double-login sequence sounds a lot like a messed-up FileVault cofig. Check its status in System Preferences > Security & Privacy pane > FileVault tab. – Gordon Davisson Feb 12 '17 at 20:10
  • Is a factory restore a viable option? This will protect the old user's data and will also solve all of your problems. – Jackson1442 Feb 12 '17 at 20:24
  • 1
    Ah, @GordonDavisson it looks like FileVault was enabled. I disabled it, then restarted my computer. I had a panic as I didn't know the username and password to login at this point. My user account didn't show up. Luckily I tried root and my root password and it worked to get me to the system administrator account. Now my files are decrypting…takes about an hour…it's in spanish, lol. – Danny Feb 13 '17 at 3:20

You must log in to answer this question.

Browse other questions tagged .