5

I have an 11" MacBook Air running El Capitan that has trouble printing. The printer is an Epson NX430 and we print to it over wifi. There are 4 different MacBooks running a variety of OS versions in the house but only the one seems to have this trouble. I've tried resetting the printer system and re-adding it. I've tried changing with the protocol from Port9100 to IPP. Nothing seems to change. Once the computer starts to report that the printer is not responding, the only "fix" is to reboot, and this generally happens after just 1 or 2 prints.

The OS can't be updated to Sierra because of a software incompatibility. For what it's worth, the problem was occurring with Yosemite as well.

Any suggestions would be greatly appreciated.

  • On the MacBook Air in question, can you go to Apple > System Preferences > Printers & Scanners. Once this opens, select the printer and on the righthand side you'll see three labels: Location, Kind, and Status. Can you advise what is listed next to Kind? – Monomeeth Feb 12 '17 at 11:57
  • The kind shows: EPSON Epson Stylus NX430-AirPrint – Josh Russo Feb 12 '17 at 17:07
  • Can you try deleting the printer from the affected MBA and adding it back manually? – owlswipe Feb 12 '17 at 20:39
  • I have tried that, though maybe I'm not following the same steps you have in mind. What is your definition of manually? – Josh Russo Feb 12 '17 at 23:13

You must log in to answer this question.

Browse other questions tagged .