3

I just restored my HD from a Time Machine backup and afterward my AHT won't work, despite the fact that I have the original install disk (10.5 Leopard, disk #2 that says it has AHT on it). AHT worked a week ago, no problem. I'm 100% sure I have the right disk. I've successfully run AHT many times using this disk in the past.

Weirdly, I can still boot to Recovery Mode from the same disk by hitting Command + R (unfortunately, can't reach AHT that way). I ran First Aid from disk just in case, no problems found. So the disk drive, disk, and keyboard all seem to work okay.

I shut down, hit D right after hitting the power button, and screen goes gray forever, never boots. Same thing occurs when pressing Option at boot to choose the boot disk... goes to gray screen, never boots. I'm using a wired USB keyboard (a Microsoft brand, but I'm accounting for default option key vs. command key vs. windows key, etc.). I also tried hitting D at different times after hitting power, before hitting power, and tried different USB ports for the keyboard. Unplugged everything. All fails.

I assume my HD recovery changed something. Apple support said they think my disk is bad, which I don't buy since it worked last week.

Perhaps relevant: I want to use AHT because — before I recovered my HD — AHT indicated I had bad ram. (Ram problems were intermittent). I wanted to determine which of my two chips was bad by using just one or the other and repeatedly running AHT to find which individual chip is bad. Currently using just one of my two 4GB chips, which I guess could be related, if it's the bad one. MacMini is a 3,1 Intel currently running 10.11.6 btw.

Thanks a lot for any advice.

  • The MacMini3,1 model identifier was used for both the early-2009 and late-2009 models. I suspect you have an early-2009 model - can you confirm this? – Monomeeth Feb 11 '17 at 1:00
  • Right. "Mac mini (Early 2009) / Processor 2 GHz Intel Core 2 Duo" – ScotttDC Feb 11 '17 at 1:22
  • Ok. Can you go to Apple > About This Mac and, after the Overview comes up, click on the System Report... button. Near the bottom of the Hardware Overview window that appears, you'll see listed your Boot ROM Version and SMC Version. Can you comment back with the versions you have installed? – Monomeeth Feb 11 '17 at 1:31
  • Boot ROM Version: MM31.0081.B06 SMC Version (system): 1.35f0 [Thanks Monomeeth] – ScotttDC Feb 11 '17 at 1:44
  • Trying to get one step ahead of you MM... should I rerun the EFI updater? Here: support.apple.com/en-us/HT201518 – ScotttDC Feb 11 '17 at 2:53
2

My first thought was that perhaps you had somehow updated the firmware and were trying to use an AHT disk that couldn't boot due to this. This is a possibility because your Mac Mini came pre-shipped with Mac OS X 10.5.6, but the firmware update (which you do have installed) requires Mac OS X 10.5.7. However, then I realised your question says you only just ran the AHT last week. So, unless you somehow updated the firmware in the past week, this isn't likely to be your problem.

Since you can't seem to get your disk to work, the only other option I can think of is to download AHT again and run it from a USB. The steps to do this are as follows:

  1. Create a bootable USB flash drive by using Disk Utility's Erase function. Make sure you choose OS X Extended for the format and the GUID Partition Map for the scheme. For the purposes of these steps, also give your USB the name AHT when you're erasing it.
  2. Download the AHT for your particular Mac Mini here
  3. Mount the downloaded image (it should mount as AHTCThree)
  4. Now you will need to copy the AHT to your USB flash drive. To start, Launch the Terminal app (usually found within the Utilities folder)
  5. In the Terminal window, enter the following:

    cp -r /Volumes/AHTCThree/System /Volumes/AHT/

  6. Now we need to make the USB flash drive bootable, so enter the following line in Terminal:

    sudo bless --folder /Volumes/AHT/ --file /Volumes/AHT/System/Library/CoreServices/.diagnostics/diags.efi --label AHT

  7. Enter your Admin password

  8. Leave the USB flash drive plugged in and restart the Mac Mini

  9. Immediately hold down the Option key

  10. Select the AHT from the list and boot up

NOTE for other readers: - These Terminal commands were written for this specific question. However, these can be adapted for your use by replacing the AHTCThree with whatever name your downloaded disk image mounted as at Step 3. For example, if at step 3 your downloaded disk image mounted as AHTEOne, then at Step 5 you would use AHTEOne instead of AHTCThree within the Terminal command.

  • Thanks a lot for giving this time and thought, MM. I will try this approach tomorrow. I worry that Option still won't work because currently holding down Option pre boot goes to a blank gray screen of death. – ScotttDC Feb 11 '17 at 5:59
  • Followed your instructions, MM. With the USB drive plugged directly into a Mini's port, pressing Option immediately after hitting power goes to gray screen of death. – ScotttDC Feb 11 '17 at 16:28
  • MM, checking my work here... I redid your instructions above, but then checked Disk Util to see if the Flash drive or AHTCThree volume were bootable in "Info." In both cases, answer is no. That means Option at boot should not work, right? – ScotttDC Feb 21 '17 at 3:33
  • Edit: meant to write "AHT volume" – ScotttDC Feb 21 '17 at 3:51
  • @ScotttDC I've just followed my steps (but for an iMac) and checked info in Disk Utility and it says No for bootable. But when I try to boot from it, it boots into AHT fine. – Monomeeth Feb 21 '17 at 6:48
0

Maybe this is a long shot, but I could imagine that repairing your recovery partition could do the trick. This article describes the procedure:

Note: This procedure can potentially destroy all data on your disk and you should make sure you have a working backup ready.

  1. Download a copy of the “Install OS X” or “Install Mac OS X” from the Mac App Store under the “Purchases” tab which matches the version of system software on your Mac (for example, the “Install OS X Mavericks” app, or “Install macOS Sierra” app)

  2. Go to the developers website here and download the latest version of Recovery Partition Creator, it’s an AppleScript that will handle the recreation of the recovery drive

  3. After the app has downloaded, right-click on “Recovery Partition Creator.app” and choose “Open” to bypass Gatekeeper

  4. Follow the onscreen instructions, and select the primary drive you want to restore a recovery partition onto (typically Macintosh HD unless you named the drive differently, or are using a separate disk

  5. Point to the Mac OS X installer application you downloaded in the first step and let the AppleScript do it’s work

  6. When the Recovery Partition Creator app is finished running, reboot the Mac and hold down Command+R to boot into Recovery and confirm the recovery partition now exists and works as intended

  • Thanks n1000, my HD doesn't have a recovery partition. You mean in my normal HD, right? I thought that was developed after my old MacMini 3,1 (early 2009). Am I wrong? – ScotttDC Feb 11 '17 at 16:03
  • Oh. I am sorry. I overlooked that you are on Leopard. So this answer does not apply. – n1000 Feb 11 '17 at 16:07
  • Now that I've dug my very corrupted SSD HD out of corruption hell, I realize you were right, n1000. The hidden volume "Recovery HD" is there after I did a clean install of 10.11 El Cap. I didn't know where/how to look before. – ScotttDC Feb 17 '17 at 19:15
  • I had assumed Cmd+R was running from 10.5 disk #2, since that disk was in the drive. – ScotttDC Feb 17 '17 at 19:20
  • @ScotttDC Too bad you had find out the hard way :/ Please consider upvoting or accepting my answer if you think it (would have) solved your question and if you think it could help others in the future. – n1000 Feb 17 '17 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .