48

I am trying to add a Google account using System Preferences > Internet Accounts.

I already tried the following.

  • able to reproduce this in 10.12.3 and 10.12.2.

  • disabled OTP, same issue

  • able to reproduce in Macbook Air and Macbook Pro

  • same issue with both Gmail account (tried two) and Google Apps account

  • I am not using any iCloud

  • it appears to be similar to this issue but the fix does not work: Can't login with Google using Internet Accounts

  • adding LinkedIn works

  • I already tried to VPN to California and Singapore to check if something is wrong with Google mirrors

  • creating a new user account and adding the Google account from there, same issue

  • as advised by Apple Support tried https://www.google.com/accounts/UnlockCaptcha

It gets stuck right after a successful login. I took a screenshot.

stuck login

Anybody experiencing the same issue?

16
  • 1
    Same here, with Mac OS 10.12.3 on multiple machines with multiple google accounts. I also created new local accounts on the machines to see if it's a keychain problem. Wondering if it's a macos problem or a google problem? Or something in our network?
    – wessel
    Feb 10, 2017 at 9:09
  • 1
    Yep same issue exactly on both my macs. I was able to set up my iPhone etc just fine but both macs just hang with the grey screen as pictured after accepting my email address and password.
    – Dave Sag
    Feb 10, 2017 at 10:26
  • 2
  • 1
    In a chat with google they said "It's a workaround for now and is still under the works by our technicians. We appreciate your patience for now." And the workaround was a suggestion to add the google account in apple mail via "Other Mail Account" . Which works, but you will miss calendar sync of course
    – wessel
    Feb 10, 2017 at 13:25
  • 1
    Looks like google fixed it!
    – wessel
    Feb 10, 2017 at 18:07

3 Answers 3

18

Combining part of your solution and part of the solution from Can't login with Google using Internet Accounts, I got mine to work again by:

  • Opening Keychain Access > login and searching for 'google', then deleting all the 'accountsync' and 'oauth' entries. The resulted in my Google account being removed from System Preferences > Internet Accounts.
  • Completing this: https://www.google.com/accounts/UnlockCaptcha

I was then able to go to System Preferences > Internet Accounts and add my Google account back. It showed the spinny wheel on the gray screen for a second, then disappeared and I was in! Mail and Calendar show my Google data now.

I have 2-factor auth enabled.

Another solution to this would be to login to your GMail account via another program that access's macOS's shared accounts, like Calendar.app.

11
  • 4
    Tried this myself, still getting problems for it
    – Peter Fox
    Feb 15, 2017 at 14:47
  • 1
    Also reporting issues with this solution on fresh install of sierra
    – Randall Ma
    Feb 15, 2017 at 18:16
  • 2
    Precisely the same problem. Again Apple is breaking essential functionality without as much as whoopsie daisy. Ever since Jobs died, quality is on the decline. Cook's not up to the job. Feb 15, 2017 at 18:59
  • 1
    Same issue as well :(. The suggested fix of removing the entries in Key Chain ended up removing the account from my other MB. Now re-adding isn't working on either of them ... Feb 15, 2017 at 20:07
  • 1
    This worked for me with two differences. First, I had to manually delete the google accounts after doing the steps above, then restart my mac, then add. It finally worked after that.
    – Sisi
    Dec 3, 2017 at 16:02
18

I found that if you have a default browser other than Safari you will face this issue.

  • Solution one: changing default browser to Safari
  • Alternative solution: When you see it stuck, start Safari and it will magically work.
3
  • 6
    Opening safari worked a charm! Jan 17 at 16:42
  • 1
    Yes, but first you need to close Safari (Command + Q).
    – Dyorgio
    Feb 16 at 11:55
  • 2
    Closing and then opening Safari was the weirdest solution ever; really didn't look like it was going to work until ti did. I thought it was going to populate the little popup browser but no… the (new) window that opened when I opened Safari was the one prompting me for my Google sign-in.
    – ijoseph
    Mar 23 at 1:00
1

I had the same issue, here's how I solved it:

  • removed all internet accounts (including icloud and game center).
  • double-checked I was logged out from my apple account
  • shut down computer
  • start computer
  • login to apple icloud again
  • login to google again

I tried deleting all passwords from keychain: no change.

1
  • For me I changed the default browser to safari and it worked Jan 4 at 9:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .