4

I want to add a Google Hangouts / Talk account to iMessage. I am on OS X 10.12.3 (Sierra). After logging in to my Google account and after entering OTP, it brings me to a white screen that appears to be stuck. I already tried disabling OTP but it still gets stuck. I attached a screenshot.

stuck google login

Anybody seeing the same issue?

  • This post is no longer relevant since it seems Google has discontinued support for gTalk services. See my answer for more information. – www139 Jun 5 '18 at 23:31
3

As of some time in 2017, gTalk is no longer available. Messages/iMessage/iChat used the gTalk service to send and receive hangouts messages. It seems Messages 11.0 (the one I'm using with 10.13.5 on late 2009 MacBook) no longer has support for any functionality whatsoever with Google services. gTalk (2005-2017) was the precursor to Hangouts though it seems Hangouts later had backward support for gTalk which is why IM clients using gTalk still worked up until some time last year.

I submitted a feature request to add support in a future version of messages. It seems all the API technology is already available and that Messages and other clients merely need to add support in future versions of the messaging clients. You can submit a feature request to reinstate some method of Google service chat IM here. I bet if enough people request the feature, we'll see client support for Google IM return in a future version of Messages. I really miss it because I hate having to visit hangouts.com or mail.google.com every time I want to interact on hangouts.

Most of the information in this post is obsolete as it seems Messages had a bug prior to gTalk being discontinued. However, it means nothing now since the API no longer exists.

Update August 2018:

I found a third-party Github project that works really well. Very nice interface. It seems that Apple is just too lazy to add support for the new API and, instead, have simply removed the ability to add other accounts in Messages. Anyway, you can find binary installers here for all operating systems (macOS, Windows, or Linux).

  • 1
    This answer seems to be the one that should get the check for correct. The only confusion could be if someone associates their gmail address with an iCloud/AppleID account - they could clearly sign in to Messages using that AppleID and need support. Worth editing to have someone check if they have an AppleID with the same user name / email as their “Google Account”? – bmike Jul 15 '18 at 17:04
  • @bmike I found a third party program that works. See the updated answer. – www139 Aug 25 '18 at 18:02
0

After retrying many times, it finally showed the following error message.

account already exists

This account already exists. You are already signed-in to the account ...

To fix I just went to System Preferences > Internet Accounts, selected the Google account, then checked Messages.

  • 1
    How did this fix it? I get this error message whether or not the "Messages" box in System Preferences is checked. – David Moles Jul 28 '17 at 17:28
0

To fix this, I had to:

  1. sign out of iCloud (System Preferences > iCloud > Sign Out)
    • note: re-enabling iCloud seems to require entering a random password from a different device, so you might want to check your iCloud device list (System Preferences > iCloud > Account Details > Devices) to make sure it only includes devices you remember the passwords to
  2. log out and back in
    • without logging out, attempting to remove the Google "internet account" would produce a Do you want to remove [this account] from all your computers using iCloud Keychain? warning
  3. delete my Google "internet account" (System Preferences > Internet Accounts > [-])
  4. recreate my Google "internet account" (System Preferences > Internet Accounts > [+]) and tick "Messages"

After this, I was able to launch Messages and see my messages, buddies list, etc., and I was able to re-sign-in to iCloud and re-enable iCloud Keychain.


As of High Sierra this no longer works.

Messages no longer appears as an option for the Google account under System Preferences > Internet Accounts, and adding a Google account to Messages as a Jabber account (with server talk.google.com, port 5223, "Use SSL" checked, and an App Password to get around 2FA) no longer works either, even after deleting *iChat* under ~/Library/Preferences as well as ~/Library/Caches/com.apple.Messages and ~/Library/Messages as recommended in various places on the internet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .